N8n cloud, MYSQL connection times out

Hello, I keep getting timed out error when I run my workflow on n8n cloud. The workflow includes inserting rows into MYSQL. The same workflow works fine on local.

Could this be a firewall issue? If so, I want to know how to whitelist n8n IP address. Having the workflow run on cloud would r-eally help me.

Thank you in advance!

Hey @olafyi!

This can indeed be a firewall issue. Can you please DM me the email you’re using for n8n.cloud? I will send you the required information then :slight_smile:



Thank you for helping out.
I’m getting the same error even after whitelisting the IP.
Is there something more I can try? :face_with_monocle:


Did you try increasing the Connection Timeout value? That might probably solve the issue. If not do let me know :slight_smile:

hello, thanks for replying.

I tried Connection Timeout value 500000 then 1000000 and it shows the same error.


I don’t have a lot of experience with MySQL, but maybe you can try out the solution mentioned here: Microsoft SQL Server credentials to be put in MS SQL node in n8n - #4 by endyk

Hello, thanks for a quick reply.
Since the same workflow runs fine on local, i don’t think I have an issue with credentials.

I didn’t activate SSL option for now. Could this be something I need to try?


Hey, yes you can try that. Since, I don’t have information on how your MySQL instance setup I am not 100% certain. But this can solve the issue :slight_smile:

doesn’t seem to work… :sob: