N8n Course 1. I am sending a message on Discord, but it doesn’t show up on the channel

Hello!
I am sending a message on Discord to the ourse-level-1 channel, but it doesn’t show up though Discord node shows succesfull completion.

I have created my own Discord server and tried to send message there - it was succesfully delivered to the channel.


It seems that incoming messages in the n8n course-level-1 channel are being filtered incorrectly.
My Unique ID: j[vKYdY68H(:WFb

Just have found the root cause of my problem. As to Notifying the team | n8n Docs explanation, the formula for Unique ID is {{ $(‘HTTP Request’).params[“headerParameters”][“parameters”][0][“value”] }}.
But that formula gets Header Auth value, not Unique ID value.
So I hard-coded Unique ID value from the e-mail received from n8n and this time the message has succesfully showed up on n8n course-level-1 channel.
Though, I still don’t know whether I can create some formula to get Unique ID value and what should it be.

Hey @avk71,

That expression looks to be correct, In the first part of the course it asks you to add the unique id as a header for the node is it possible that you missed this step or tried to do something else?

Jon, hi!

As you can see in the attached screenshot from n8n couse-level-1 Welcome e-mail, Unique ID is a 32-character string, but Header Auth value is a 15-character string, so they values are different.
{{ $(‘HTTP Request’).params[“headerParameters”][“parameters”][0][“value”] }} returns Header Auth value, but Discord channel bot allows only messages with Unique ID, and drops them otherwise.
I could see from community forum that some people had the same issues - so they had to hard-code Unique ID into the message instead of the formula above and after that their issues have magically gone.

Hey @avk71,

Both values are different, So you should be creating a credential with a header type for api_key but for unique id it should be set in the first http request node as a header value.

This should result in your HTTP Request node looking like this…

The idea is to use the value inputted as a header parameter here and the path for that is {{ $('HTTP Request').params["headerParameters"]["parameters"][0]["value"] }}

This can also be checked in the expression editor here…

I suspect in some of the cases the first step has not been correctly followed or misunderstood although we did change that expression a couple of months ago as well so it was wrong for a while.

1 Like

Jon, hi!
I’ve thoroughly read your answers and course materials. You’re right, I just mixed up Unique ID and Header Auth values.
Now all works fine! Thanks a lot for your detailed and quick responses!

2 Likes