N8n Custom Docker Issue

Describe the problem/error/question

We Have Integrated n8n in docker and when we deployed n8n in server. After Some time it is taking resource utilization 150% in server. How to optimize this utilization of n8n.

Information on your n8n setup

  • n8n version: 0.233.1
  • Database (default: SQLite): PostgreSQL
  • n8n EXECUTIONS_PROCESS setting (default: own, main): default
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: windows

Hi @Tanay_Acro,

It’s good to see you again! :dizzy:

This will depend greatly on how you’re using n8n and even in how you are managing your Docker container resource limits and allocations.

If, for example you are running something 200 executions at the same time, it would be worth considering creating a second or third instances and dividing the load between them.

You could also go over how you manage your workflows. Implementing a timeout option, for example; rethinking how efficient each workflow is and maybe rearanging the node number or data processing steps.

Here is n8n’s documentation on how to manage your self-hosted instance as it scales and needs more resources: Overview | n8n Docs

A great tool is n8n’s Benchmarking Framework GitHub - n8n-io/n8n-benchmarking, which provides you with insights into how your workflows perform under different loads, helping you identify optimisation areas. https://docs.n8n.io/hosting/scaling/performance-benchmarking/

If you’re not already, consider setting up queue mode.

Hope this helps!