N8n desktop app requires login now?

Describe the issue/error/question

I’ve been using the n8n desktop app (OSX M1) for about a month now to get a lay-of-the-land for creating workflows. I wasn’t able to use the app last week. Today when I tried using it, my workflow failed with 401 errors. I decided to kill and restart the app and I was presented with a login screen. My username(ie email address)/password didn’t work. The app doesn’t allow a reset password (says the functionality doesn’t work yet). I tried logging in via browser but that takes me into a workflow asking what type of account I want (trial or paid).

Is this properly functioning?

Information on your n8n setup

  • n8n version: 1.6
  • Database you’re using (default: SQLite): default
  • Running n8n with the execution process [own(default), main]: default
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: desktop app

I was able to get things going by resetting the password (Auth → reset password) and making sure that on restart, I skipped setting up an account. My workflow is there still, fortunately. This was a rather odd incident. Is this normal?

Hi @Jim_Conner, welcome to the community!

n8n would only ask for a username/password if you’ve previously set it. If you have accidentally set a password on the desktop app, you can reset it as you have described (and then skip the account creation).

As for logging in on the browser I suspect you tried logging in on the n8n website - this would be a separate account from the n8n app running on your desktop.

1 Like