N8n docker keeps crashing on startup

I have some issue with a workflow and now with docker that keep crashing.
After I run a workflow the docker instance crashed and keep crashing on start.

I’ve temporary resolve the issue migrating to branch-master instead of latest release. But after I tried to modify and run again the workflow the docker instance crashed again and now it can no longer start.

I’ve tried to migrate to different version, also downgrade, but nothing works.

Using docker logs when i run the instance i get this error:

License manager not initialized
Last session crashed
Error: Error parsing n8n-config file “/home/node/.n8n/config”. It does not seem to be valid JSON.
at getUserSettings (/usr/local/lib/node_modules/n8n/packages/core/dist/UserSettings.js:126:15)
at Object.prepareUserSettings (/usr/local/lib/node_modules/n8n/packages/core/dist/UserSettings.js:20:24)
at Start.init (/usr/local/lib/node_modules/n8n/packages/cli/dist/commands/BaseCommand.js:60:29)
at Start.init (/usr/local/lib/node_modules/n8n/packages/cli/dist/commands/start.js:143:9)
at Start.run (/usr/local/lib/node_modules/n8n/node_modules/.pnpm/@[email protected]@[email protected][email protected]/node_modules/@oclif/command/lib/command.js:42:13)
at Config.runCommand (/usr/local/lib/node_modules/n8n/node_modules/.pnpm/@[email protected][email protected]/node_modules/@oclif/config/lib/config.js:173:24)
at Main.run (/usr/local/lib/node_modules/n8n/node_modules/.pnpm/@[email protected]_@[email protected][email protected]/node_modules/@oclif/command/lib/main.js:28:9)
at Main.run (/usr/local/lib/node_modules/n8n/node_modules/.pnpm/@[email protected]@[email protected][email protected]/node_modules/@oclif/command/lib/command.js:43:20)

Information on your n8n setup

  • **n8n version: 0.234.1
  • **Running n8n via Docker
  • **Operating system: Ubuntu

Hey @Mino_Bedin,

Looking at the error it looks like the issue is with the config file

Error parsing n8n-config file “/home/node/.n8n/config”. It does not seem to be valid JSON.

Are you able to share the contents of that file but replace any important values with [REMOVED] like the encryption key value.

I can’t think of why why running a workflow would cause an issue so it could be that the issue is not seen until the workflow runs.

I have the same issue, here is my variable file.

Hey @V_M,

Is it the same wording? It could be that for you Railway doesn’t provide acess to the file but your settings also look a bit odd to me as you are using HTTPS and port 443 but have not set the SSL certiticate to use. If Railway is handling this you would just use HTTP and 5678. The value you have for n8n_host looks to be incorrect as well and that is what you would normally use for WEBHOOK_URL.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.