N8n does not run on docker

Describe the problem/error/question

I’ve installed n8n on docker (in ubuntu), using the minimal compose settings described here : How to configure n8n to be used over local network.

The container is deployed but I get a 404 when trying to open the website (both on http and https). When I looked at the container’s log I get the following error message on repeat:

What is the error message (if any)?

(node:7) [EACCES] Error Plugin: n8n: EACCES: permission denied, open ‘/home/node/.n8n/config’ module: @oclif/[email protected]

The static folder is empty.

Please share your workflow

Thanks !

  • n8n version: latesr
  • Database (default: SQLite): SQLite
  • n8n EXECUTIONS_PROCESS setting (default: own, main): NA
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: Ubuntu Server 22.04.3 LTS

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @carlosyanez,

Welcome to the community :cake:

It sounds like you have a permisison error, Can you share how you are running n8n?

Hi @Jon ,
Everyting on the deployment seems to be rather vanilla.

I’'ve deployed on docker, using the n8nio/n8n image. Docker is running in Ubuntu. I’ve deployed through portainer. Local folder didn’t existing prior to deployment, so docker/portainer created it and assigned owner and file permissions. Portainer server is using their standard image, no customisations. I’ve already deployed other containers using the same method and no issues there.

Is there any other setting I should be looking at?


Hey @carlosyanez,

None that I can think of, the error is very specific about the permission. What path did you map the volume to and have you tried changing the user or anything?

Hi @Jon ,

my current docker compose:

image: n8nio/n8n:latest
restart: unless-stopped
- 5678:5678
- GENERIC_TIMEZONE=Australia/Melbourne
- /opt/docker/n8n:/home/node/.n8n

(it is properly idented)
The folder is created on deployment.
I also tried with ~/n8n

It was permissions - it looks that something did change on docker/portainer…fixing the permissions from ubunt got n8n running…

1 Like

Hey @carlosyanez,

That is good to hear, Thanks for letting us know.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.