N8n doesn't start on uberspace.de

Describe the problem/error/question

Hello forum,

this is my first message here as I’m starting with n8n right now and really enjoying it. I try to install n8n on my webhoster uberspace.de and followed these uberspace related sources: 1 and 2.

It doesn’t work with the above documentation. Even a npx n8n results in a simple return code 1, see infos below.

I tried different stuff like:

  • deleting the .n8n folder
  • uploading an local version of my .n8n folder (from Mac)
  • tried the npx and the described way via daemons
  • reading the ‘whole’ forum trying to find a workaround / similar situation

What is the error message (if any)?

➜  ~ npx n8n
➜  ~ echo $?
➜  ~ export N8N_LOG_LEVEL=debug
➜  ~ npx n8n
2023-08-13T15:11:31.127Z | debug    | Lazy Loading credentials and nodes from n8n-nodes-base "{\n  credentials: 320,\n  nodes: 431,\n  file: 'DirectoryLoader.js',\n  function: 'loadAll'\n}"
➜  ~ echo $?
➜  ~
➜  ~ node -v
➜  ~

Please share your workflow

n8n doesn’t start

Share the output returned by the last node

Doesn’t even start

Information on your n8n setup

  • n8n version: 1.1.1
  • Database (default: SQLite): default
  • n8n EXECUTIONS_PROCESS setting (default: own, main): default
  • Running n8n via (Docker, npm, n8n cloud, desktop app): npm/npx (nodejs 20.5.0)
  • Operating system: CentOS, Linux xxxx.uberspace.de 3.10.0-1160.80.1.el7.x86_64 #1 SMP Tue Nov 8 15:48:59 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

Any ideas from the pro’s?

Kind regards

After writing the whole post i saw that there is an version 1.2.1 available. Now I get a more detailed error message:

➜  ~ n8n start
2023-08-13T15:30:18.963Z | debug    | Lazy Loading credentials and nodes from n8n-nodes-base "{\n  credentials: 344,\n  nodes: 431,\n  file: 'DirectoryLoader.js',\n  function: 'loadAll'\n}"
2023-08-13T15:30:19.866Z | error    | Error: There was an error initializing DB "{ file: 'ErrorReporterProxy.js', function: 'report' }"
2023-08-13T15:30:19.866Z | error    | DriverPackageNotInstalledError: SQLite package has not been found installed. Try to install it: npm install sqlite3 --save "{ file: 'ErrorReporterProxy.js', function: 'report' }"

I tried the supposed npm install sqlite3 --save / npm install -g sqlite3 --save but the error persists.

Any ideas?

Hi, Uberspace provides sqlite https://manual.uberspace.de/database-sqlite/?highlight=sqlite

You could contact their support, keep in mind that you’ll need webbackends


1 Like

Hi @SkyIsTheLimit, you could consider using Postgres instead if sqlite causes trouble. Once set up using the instructions provided by Ubserspace n8n starts fine. I just tested this:

The exact command was this:

DB_TYPE=postgresdb DB_POSTGRESDB_HOST=localhost DB_POSTGRESDB_USER=mutedjamn8n DB_POSTGRESDB_DATABASE=mutedjamn8n DB_POSTGRESDB_PASSWORD=myDatabasePassword DB_POSTGRESDB_PORT=5432 npx --node-options="--max-old-space-size=512" n8n@latest

That said it seems Uberspace kills processes if they use too much memory on the host and I suspect this might also happen in other situations. Unfortunately as a user it won’t be easily possible to identify what happened as you can’t access the pacct file (which makes sense for security reason, seeing an Ubserspace host is shared by many users). Docker is also unavailable on Uberspace.

So while I have a lot of sympathy for Ubserspace it might not be the ideal host for n8n and you might want to consider using an alternative hoster providing you with full access to a VM (Like Hetzner or Digital Ocean for example). This allows you to use docker which should prevent you from hitting compatibility issues due to the packages available (or not available) on your system.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.