N8n npm: “Connection lost”

Hi everyone,

I’m opening this post because I’d like to understand something.

For my studies, I’d try n8n.

I have decided to deploy n8n on a VM without use docker but npm.

My VM running Debian 11 with node.js 18.16.0 and the latest version of n8n.

I have modified N8N_HOST environment variable to join n8n by IP address.

I have no problem to access to n8n via the VM web browser but if I try to join the URL via another VM in the same LAN other than the WM hosting n8n (even if evething look work normally), I can’t launch a workflow the error “Connection lost” systemically occurs.



I have tried many things but the result il always the same. Do you have an idea? Am I doing something wrong?

Information on my n8n setup:

  • n8n version: 0.227.0
  • Database: SQLite
  • Running n8n via: npm
  • Operating system: DEBIAN 11.7

Hey @Dradibou,

Welcome to the community :raised_hands:

Can you try setting the VUE_APP_URL_BASE_API env option to be the same IP and see if that helps, It could be that it is trying to use localhost still.

Hi @Jon ,

thank you for your response.

I solved my "lost connection " problem without using the “VUE_APP_URL_BASE_API” environment variable. In fact, it was a firewall rule a little too aggressive on the client VM.

I’m sorry for the inconvenience.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.