N8n on npm failed to start

My n8n last working in April, I don’t know what version it was but I must had updated to another 0.2xx version and not using it since.

I tried to use it beginning of this week and encountered initializing n8n process, and it was stuck forever. I’d spent last 2 days trying to fix and encountered various errors. I tried to install [email protected], [email protected], [email protected], and it ended up with license manager not initialized. None of the following steps I tried works:
-VACUUM the sqlite3,
-renamed the existing .n8n folder
-uninstalled nodejs and reinstall
-clear the %appdata%.n8n folder
-launch npx n8n as per documentation

With n8n latest installation or any version 1.xxx, n8n didn’t return any output and exit. I’d but none works. I’d backup my workflow back in April, so the plan is to get a fresh copy of n8n and import the workflow. Why can’t n8n working, I’d set N8N_DIAGNOSTICS_ENABLED=true but not seeing any log.

Information on your n8n setup

  • n8n version: 1.3.1
  • Database (default: SQLite): sqlite
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): npm
  • Operating system: win x64

HI @engowen :wave: Sorry you’re running into this!

Can you set your N8N_LOG_LEVEL to debug and see if that works to give you some logging information on this one? :eyes: You can read more on log levels here: Logging | n8n Docs

1 Like

Sorry, this is my problem. Apparently I tried to setup and experiment URL rewrite in IIS around June and had totally forgotten about it.

Thanks to docker i realised the port has been used.

and that I can start my n8n again in npm. If starting n8n on npm provide the same feedback as docker then it could have saved me debugging hours :sweat_smile:


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.