N8n scaling mode, webhook cannot GET /

Describe the problem/error/question

I’ve configured n8n to run on ecs, the main process and the worker process seem to come up fine but when try to access the webhook instance I am seeing errors. They are hosted on separate dns entries, so it will be n8n.company.com n8n-queue.company.com and n8n-webhook.company.com, so routing of traffic does not seem to be an issue.

What is the error message (if any)?

Cannot GET /

Please share your workflow


Information on your n8n setup

  • n8n version: 1.6.1
  • Database (default: SQLite): postgres
  • n8n EXECUTIONS_PROCESS setting (default: own, main): default
  • Running n8n via (Docker, npm, n8n cloud, desktop app): docker
  • Operating system: linux

Hi @fclark182, welcome to the community!

/ is not a valid webhook path, so a 404 response seems to the be the correct response here.

Have you tried activating at least one workflow with a webhook node listening to GET requests, and then tried to access the respective webhook path?

Hi thanks for getting back to me. No I haven’t actually so I will try that.
One thing as well that I should have mentioned is that invite links do not work either, the invite link is generated as https://n8n-webhook.company.com/signup?inviterId=blahblahblah and this returns Cannot GET /signup. Is this something I have misconfigured?

Hi @fclark182 I suspect this could indeed be a problem with the configuration. Your webhook processor wouldn’t need a public hostname on its own (though I can see how our documentation suggests this could be a possible approach, I’ll suggest a change for this internally).

Instead you’d have a single public hostname pointing to your load balancer (or reverse proxy), then distribute requests as described here:

  • Redirect any request that matches /webhook/* to the webhook servers pool
  • All other paths (the n8n internal API, the static files for the editor, etc.) should get routed to the main process

Perhaps you want to give this a go?

Alternatively you can also replace the webhook hostname in https://n8n-webhook.company.com/signup?inviterId=blahblahblah manually with your main instance hostname for a quick test, but this is of course not a long term solution.

looks like the mistake was mine, I hadn’t set N8N_EDITOR_BASE_URL
Thanks for the help!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.