N8n traefic

For examples from templates:

In my experience “connection lost” happen sometimes if your N8N instance does not have enough memory for the workflows you are running.

basically the instance crash & restart itself, creating the connection lost issue. Give it more memory.

Whoops sorry, wasn’t my intention to get this mixed up

just to finish on my item, I don’t think this is mixed content issue, the page itself does not have any non HTTPS elements that I can find and the DevTools do not show any unsecured mixed in content.

Ram? Sdd? How many memory ?

It looks to me that you are on HTTPS so it would be secure and I am fairly sure that Chrome only shows that message on mixed content. If you can DM your host and a test account I can take a quick look to confirm.

Have you checked the docker logs and the browser dev console / network tab to see if there is any errors in there?

this is error

This is log docker

Apparently there really is not enough memory if I understand correctly … the question is how to solve this problem without physically increasing the RAM?


Not enough memory could explain why the cert is timing out as well maybe the Pi can’t deal with the response. Normally the solution would be to change your workflow so that it is not using so much data in one go but your workflow is really small.

What Pi are you currently running on / what is the memory available?

Pi 4 2Gb с SD 128GB

Are you only using the Pi for n8n? It should run ok but if you are working with a lot of data or large files

Not only for n8n…docker-compose->traefik->n8n

Have you tried using a smaller dataset to see if that helps?

with smaller files there are really no errors

I think that would maybe suggest that you are hitting the limits of your configuration, You could maybe try and see if allocating more memory to the container helps I think docker has a -m option that lets you set what the container can use. I know Node has an option you can set as well which would need to be an env variable but it would be a case of finding what option works for you.

I think you might be better of doing the install with npm and using pm2 to run it as a service that way you can use all the resource available on the Pi.