N8n traefic

Hello everyone, an error when starting on the screen, I did everything according to the instructions, n8n itself works, but the certificate is invalid, the ports are open, the firewall rules do not restrict the work, tell me what could be the problem? how to make the certificate valid and there was no such error


It could be the email addressed used, That seems to suggest a timeout though. It could be that Lets Encrypt is not able to speak back to the Traefik service as well, What firewall rules do you have in place?

Thanks, here is what the iptable show


What about on your router do you also have the port forwarding set up there?


That looks right to me, I take it you don’t don’t have any other services listening on 80 and 443 on your pi?

What is strange is the challenge json looks to be ok and the error appears to say it can’t connect to your IP because of a timeout or that is how I am reading that error anyway. Have you checked the Traefik docs?

About other services listening on 80 and 443 ports:

Please tell me which traefic doc to check? …I have already broken my brain :((((((


That I am not sure about, I would maybe start with troubleshooting or anything they have on network routing.

I take it the domain is a proper one as well and not just an internal domain?

Please check if there is an error here:

Might be worth removing the --tunnel option you shouldn’t need that.

I’m having exactly the same issue, deployed using the provided docker-compose file
everything seems to be running smooth regarding the app itself and traefik but SSL cert doesn’t pick up
even tho it shows in the browser as a LetsEncrypt certificate.

I have also the acme.json file generated with it’s keys

not sure what I can bring more to help debug this…


Hey @rmdes,

What do you mean when you say the cert doesn’t pick up but it shows Lets Encrypt? If you are seeing a certificate it sounds like it has worked but maybe it is showing as an invalid certificate because of the hostname being used.


The browser even say the cert is valid

Alright so in that case the issue is probably not with Traefik or n8n directly there is possibly some data being loaded over HTTP. Did you set VUE_APP_URL_BASE_API to https://automate.yourdomain.com?

tell me in the settings we should use host with subdomain(n8n.example.xyz) or just domain example.xyz

Host is normally set as ${SUBDOMAIN}.${DOMAIN_NAME} so if your domain was google.com and your subdomain was n8n it would use n8n.google.com which should be the same address you access n8n from.

Looking at your earlier screenshots you have a subdomain of n8n and a domain of n8nni______.xyz so your host value would be n8n.n8nni______.xyz

I did,

my sub is automate
my domain is set domain.com

the instance is running on automate.domain.com

Is this to be done on the .env file ?

I simply used the provided .env model and the provided docker-compose
the only thing I did was to create the volumes, adapt the .env, prepare my dns zone
and that’s it.

Great, can you share your settings, I’m still failing :frowning:

Stupid question … n8n works for me without a certificate, i.e. with an invalid certificate, BUT… there is a problem with the Read PDF node, when it is executed, the status “Connection lost” appears, and the download is forever…

Hey @rmdes

There are 2 different issues in this thread, The issue you are seeing is not the same as the issue @FIRE_TIKTOK has.

In your case in theory setting the env variable I mentioned may help but it looks like you have a cert and it is loaded over HTTPS so it is just mixed content causing your issue.

@FIRE_TIKTOK the config from @rmdes may not help you, What download are you referring to with Read PDF node? If you check the browser dev console does it show anything?