N8n ui loads very slow with 6k workflow

Describe the problem/error/question

We have 6000 workflow half of them is active. We can barely use n8n ui. It loads very slowly. I watched network requests. Latest returned request took 2.13 sec. I guess something wrong with ui rendering. It couldn’t draw that many workflows.

I didn’t open issue at github because i don’t know if n8n could work with that much workflow smoothly. As a solution i had to delete passive workflows. After that ui now renders like 4-5 seconds, which is okey for now.

I want to hear your opinions. Can we use 6k workflow? What should we do to make ui faster?

Information on your n8n setup

  • **n8n version: 0.219.1
  • **Database (default: SQLite): postgresql
  • **n8n EXECUTIONS_PROCESS setting (default: own, main): own
  • **Running n8n via (Docker, npm, n8n cloud, desktop app): docker
  • **Operating system: default n8n image

Hey @Mustafa_fimple,

I would start with updating your n8n instance, We have made a lot of improvements recently to the queries we run which should help speed that up. Some of it will also come down to the speed of the database but as a starting point try the update and make sure you check the migration guide before doing it.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.