New n8n Version

Okay, I think I have it.
After the change from main to own I had restarted n8n with pm2 restart n8n.
But instead of pm2 shutting down the old instance. I had started a new one on a different port.
“process”: “own” I think should work now.
I restarted the “real process”.
Even if this strange dialog comes anyway:

Just to make sure I fully understand this @lublak, the only difference between working and not working is EXECUTIONS_PROCESS=own vs. EXECUTIONS_PROCESS=main for you? With main not showing any execution process and own working as expected with the exception of the pop up?

The popup itself is a generic message while n8n waits for a trigger to start. With EXECUTIONS_PROCESS=own, n8n would spin up a new Node.js process for your workflow executions, if this takes a bit longer than anticipated this message would pop up (though it doesn’t really make sense here, I’ll add it to our backlog for a fix).

Yes, as far as I have tested it, it is displayed successfully with “own” and not at all with “main”.
Possibly it can also be due to a very strong delay which can be seen with “own”. Maybe the delay at “main” is much bigger.

Can confirm, with EXECUTIONS_PROCESS → own it seems to be working.

But don’t know why this is happening.

Also EXECUTIONS_PROCESS own has very slow start up.


So, I couldn’t reproduce this problem simply by setting EXECUTIONS_PROCESS=main on a fresh instance so far unfortunately, but I encountered a similar behavior as originally reported on my own instance following the 0.202.1 upgrade. It would usually disappear after (force-)reloading the page, however, I had to log in again when doing so.

The login problem has been fixed here. This has also fixed the “no execution progress” problem for me, though I am not 100% sure how these two would be connected (still seems worth pointing out). I’ve tested this by deploying docker image n8nio/n8n:branch-n8n-5596 including the fix on my server. The image is publicly available but of course not a released version of n8n, so you might not want to use it in production.

Seeing the fix is of course also part of the upcoming release, perhaps you can give it a go once n8n 0.203 becomes available and confirm whether the problem persists?

I will try it again as soon as 0.203 comes out and report here.

0.203 has been released. Did you try it? Is it fixed?

Not rly. Still slow startup. But it shows a spinnger with: EXECUTIONS_PROCESS=own

What I also noticed: Not only the first time start takes so long, but also if you want to start from a certain node again. (The previous data of the previous nodes are available).
Until it then really starts times it takes just as long. Btw it was not so before where the “start” node was still present.
I do not know exactly at which update it became so slow.