New OAuth2 Credentials Suddenly Not Working

Describe the problem/error/question

I’m running a self-hosted instance of n8n. I’ve set up multiple OAuth2 login credentials without issue. But recently, I’ve suddenly been unable to add any more.

The OAuth2 credentials I’ve already set up are still working fine.
But whenever I try to add a new one, it gives me an “Unauthorized” error, with no extra info.

I’ve tried a few different OAuth credentials (Various Google apps, Notion, Eventbrite) and am getting the same error across all of them.

For example, when I try to add a Google Drive credential:

  • I fill out the Client ID & Client Secret
  • I select “Sign In With Google”
  • I select the correct Google account
  • I click “Allow” to the OAuth connection request
  • It returns “Unauthorized” on a black screen (see below)

I’ve confirmed that my OAuth credentials are set up properly on Google’s side (and like I mentioned, I also tried this on non-Google connections, and got the same error). I’ve tried it from multiple Google accounts as well, same result.

I began noticing this on version 1.30.1. I tried downgrading to earlier versions to see if it would fix it (1.30.0, 1.29.0) but the issue persisted. I’m currently unable to update beyond 1.30.1 on the Docker image (I think there’s a bug that’s being fixed that’s preventing me from updating, but that’s a separate issue)

What is the error message (if any)?

The popup window turns black, with just the word “Unauthorized”. No extra info in the docker log

Please share your workflow

(This isn’t a specific workflow, it’s when I try to add new credentials. This is whether I do it in a specific node, or on the “Credentials” tab)

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node


Is this an n8n issue? Or maybe something’s going on with my Cloudflare hosting? How can I narrow down the problem?

Any help is appreciated!

Information on your n8n setup

  • **n8n version: 1.30.1
  • **Database (default: SQLite): didn’t change this, so probably SQLite
  • **n8n EXECUTIONS_PROCESS setting (default: own, main): didn’t change anything, so I’m guessing default
  • **Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • **Operating system: UNRAID

Answering my own question again…
I’m able to add new OAuth credentials if I access n8n from my external domain.
When I try to add credentials via my local ip, it fails. But the external url allows me to properly add them.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.