Nextcloud file share node

I just tested, two slashes do not seem to break anything, it still works fine for me.

So I assume that the path is wrong or the user does not have access. You can use “Folder → List” starting with the path “/” and see if it displays the parent folder and go then down one level at a time.

hello @jan , is this the folder path? it seems like when i key in this, i have problem

Can you try to add a slash in front of it?

This is the description of the “Folder Path” parameter:
The file path of the file to share. Has to contain the full path. The path should start with "/"

Hello @jan when i just key in “/test” it is able to list out the file in the folder.

but when i share the file path, it is unable to located the file.

Are you using the exact path you got from the folder:list operation?

hello @RicardoE105 the exact path return an error…

but if i just use “/test” , it is working for “list”, but not working for “share”

For me, it looks like you have to combine both paths to get the actual full path. So:
/test/es/htoolin/...

Hello,

it is still not finding the file…


i try with a single “/” and is unable to find the file too…

I have another problem with nextcloud credential as well.

it seems like it is forgetting and i have to keep reconnect , re grant access with same setting…

24.10.2021_01.16.35_REC

I have tried looking and can’t see it but what version of n8n are you running and how are you running it?

hello @Jon this is the version. running self hosted on unraid.

Looks like something very strange is going on. I just tested. It looks like the paths do not have to get combined, it really displays the absolute one. So I assume that there is maybe something misconfigured on NextCloud because if you tell it to list /test it should not return something from a different folder like in your above screenshot a file in es/htoolin/test/.... Another thing that makes me believe that, is that it returns paths with double slashes like es/htoolin//test/.... I would check in the NextCloud community they probably have a better idea what is going on here. But can currently not see anything that makes me believe it is a problem on the n8n side.

4 Likes

Hello ,

I try again on these few days with another set of folder and it seems like i am still unable to share the file.
Below is how i connect my 2 nextcloud nodes. the first node list path, 2nd node will use the path for share setting.
image

i am able to list out the files as shown below.

However, during sharing, I face the same problem as earlier.

I use expression to setup the file path.

After adding forward slash “/” , I am still getting the same error.

Can you do a {{decodeURI($json["path"])}} to see if that fixes the issue?

hello @RicardoE105 this morning when i wake up and try out, the new design of the node look cool…

image

anyway, back to the problem i am facing, even with {{decodeURI($json[“path”])}} , i am still getting error locating the file.

Hello, anybody having similar problem as mine?

I have the same problem.

Not sure if webdav access token can be used to create a share.

Hello,
Count me in, I am also having exact same problem.

You be sure, that is the problem. Webdav access cannot create a share indeed.
How I solved my problem;

I created two authentication option for nexcloud node.
One is to upload and create content on your server
Authentication url must be: https://nexcloud.example.com/remote.php/dav/files/USERNAME/

To create a share, URL must be https://nexcloud.example.com/
That’s it

2 Likes

Thx so much for sharing @No_Name, as mentioned over in the other thread (Nextcloud share file node cannot find file - #10 by MutedJam), I’ll add this to our bug tracker for a closer look!

1 Like