NocoDB node: correct syntax for selecting rows

Describe the problem/error/question

I want to get as a result of the row operation “Get many” in the NocoDB node only the rows I filtered already in the NocoDB database. This worked until recently, now I always get all the items.

Now I want to use the option “Filter by Formula” and I tried the following:

AND(IS_AFTER({CreatedAt}, ADD_DAYS(TODAY(), -7)), {TGCRelevance} < 3)

What I wanted to achieve is the following:

  1. Select only the rows which have been created in the last 7 days
  2. Select the rows which have a value of less than 3 in the column “TGCRelevance”

What is the error message (if any)?

ERROR: Your request is invalid or could not be processed by the service

422 - {“msg”:“Invalid field: undefined”} - Invalid field: undefined

Please share your workflow

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 1.9.3
  • Database (default: SQLite): SQLite
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Yunohost
  • Operating system: Debian or Ubuntu

I found the answer myself by having found the right reference in the nocoDB documentation: REST APIs | NocoDB


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.