NocoDB unable to download file

When I try to download file I get “Unexpected token o in JSON at position 1”

Information on your n8n setup

  • n8n version: 1.16.0

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hi @Valdri, I am sorry you’re having trouble. I was able to reproduce this problem and have added this to our engineering team’s bug tracker for a closer look and fix.

In the meantime, perhaps you want to disable the “Download Attachments” option on the NocoDB node itself and instead handle the download through a separate HTTP Request node?

Here’s an example workflow:

This worked fine for me, the HTTP Request node downloads the first file in my Attachment field using the path it receives from NocoDB:

The only things you’d need to adjust here are the URLs, credentials and field name I have in use since they of course differ in my own test database.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.