Node type "n8n-nodes-base.mySql" is not known so can not run it!

Describe the problem/error/question

When i run it manually node mysql works fine, but when i run it on a schedule or through the webhook gives the error: “Node type “n8n-nodes-base.mySql” is not known so can not run it!”.
If you put a direct start mysql just ends with an error:
“Problem with retry
Cannot read properties of undefined (reading ‘nodeExecutionStack’)

What is the error message (if any)?

" Node type “n8n-nodes-base.mySql” is not known so can not run it!"

Please share your workflow

Information on your n8n setup

  • **n8n version:0.228.0
  • **Database (default: SQLite):Postgree
  • **n8n EXECUTIONS_PROCESS setting (default: own, main):queue
  • **Running n8n via (Docker, npm, n8n cloud, desktop app):docker
  • **Operating system:portainer(ubuntu)

Hey @roughriver74,

That is a bit odd, I have just set up a quick test and I was not able to reproduce it but I also wasn’t running in queue mode so there could be something there. I take it all of your workers are on the same version of n8n? I don’t think we ever actually released 0.228.0 on Docker as well are you using a custom image or are you on 0.228.1 / 0.228.2?

I downgraded to Version 0.227.1 and it all worked!


Hey @roughriver74,

What version were you actually running on before the downgrade?

relevant right now

Hey @roughriver74,

Nightly is very brave and is expected to have some issues, I would recommend using either the latest or next tags.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.