NodeOperationError: Failed to connect to Zep server

Hi!
I use n8n cloud, setup my own Zep server, create credentials for using in n8n. Test connection to Zep works successfully. After that I create Zep Vector Store Node in my workflow with this credentials and try to execute node. As a result I get:

NodeOperationError: Failed to connect to Zep server. Please check that:

  • the server is running
  • the API URL is correct
  • No other process is using the same port

My Node data:
{
“meta”: {
“instanceId”: “734ca5a4249f71011a4ba398e35b186698914b6cf854134992a59564cdd44c32”
},
“nodes”: [
{
“parameters”: {
“mode”: “insert”,
“collectionName”: “n8n”,
“options”: {
“embeddingDimensions”: 256,
“isAutoEmbedded”: true
}
},
“id”: “3e4386d0-aa30-4249-89d6-1a21bb37ca58”,
“name”: “Insert to memory (ZEP)”,
“type”: “@n8n/n8n-nodes-langchain.vectorStoreZep”,
“typeVersion”: 1,
“position”: [
840,
640
],
“alwaysOutputData”: true,
“notesInFlow”: true,
“credentials”: {
“zepApi”: {
“id”: “tTkJYDxvcIhe9pAi”,
“name”: “Zep Api account”
}
}
}
],
“connections”: {},
“pinData”: {}
}

Any ideas what is the reason of this issue?
I found rhan n8n send this request to my Zep Server: http://*IP_ADDRESS:8000//healthz
and my server return 404 code. How to fix it?

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hi @brom38, I am sorry you’re having trouble. Just to confirm have you by any chance added a trailing slash at the end of the API URL field in your Zep Api credentials? Not all n8n nodes will detect and handle these automatically, and seeing you observed a request to http://*IP_ADDRESS:8000//healthz I suspect the Zep ones might fall in this group.

So it might be worth double-checking your URL looks like http://localhost:8000 rather than http://localhost:8000/.

1 Like

Hi @MutedJam! Thank you for help! It works. I didn’t notice the double slash.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.