Nodes do not return results when Execute is clicked

My triggers and nodes do not return results when pressing execute until I stop, but the Executions tab still reports successful execution and returns results. Please refer to my screen record:
Video: Video Unavailable

Information on your n8n setup

  • n8n version: 1.23.0
  • Database (default: SQLite): SQLite
  • n8n EXECUTIONS_PROCESS setting (default: own, main): own
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: Ubuntu 20.04

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

I have updated the requirement informations, please give me some advices.

Hey @Nabi188,

Welcome to the community :cake:

I suspect there could be an issue in the configuration as I am not able to reproduce this, Are you using something like Cloudflare in front of n8n or maybe a reverse proxy that doesn’t have websockets enabled?

Thank you for the respond,

I’m not using Cloudflare. I just used nginx as a reverse proxy. BTW when I use the older version of n8n (1.19.0), it works perfectly.

server {
    server_name n8n.websitegiare.net;
    location / {
        proxy_pass http://localhost:5678;
        proxy_set_header Connection '';
        proxy_http_version 1.1;
        chunked_transfer_encoding off;
        proxy_buffering off;
        proxy_cache off;
    }

    listen 443 ssl; # managed by Certbot
    ssl_certificate /etc/letsencrypt/live/n8n.websitegiare.net/fullchain.pem; # managed by Certbot
    ssl_certificate_key /etc/letsencrypt/live/n8n.websitegiare.net/privkey.pem; # managed by Certbot
    include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
    ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot

}
server {
    if ($host = n8n.websitegiare.net) {
        return 301 https://$host$request_uri;
    } # managed by Certbot


    listen 80;
    server_name n8n.websitegiare.net;
    return 404; # managed by Certbot


}


Hey @Nabi188,

Your nginx configuration is not configured to use websockets correctly which will cause some issues. I would start by updating your location to be something like the below which has worked for other users.

location / {
        proxy_pass http://localhost:5678;
        proxy_set_header Connection 'Upgrade';
        proxy_set_header Upgrade $http_upgrade;
        proxy_http_version 1.1;
    }