Nodes Output Data not showing up

Hello folks,
thanks for the great project and contributions.

I’ve search on Github and this forum but found nothing, so apologies if that has been already addressed somewhere.

As simple as the title: the Output Data section doesn’t show up in the Expression editor (see attached screenshot).

My understanding is that, for the data to show up, nodes must be linked and at least one execution should have happened. If that’s still the case, I comply with both requirements.

Am I missing something?

Thank you!

Screenshot_2021-01-02_18-22-56|690x208

Welcome to the community @dab!

So the Webhook-Node displays the little green “1” in the corner and it for sure has the body you are referencing? Can you please post a screenshot of the Webhook-Node with JSON selected.

If I’m reading it correctly, it should (attached screenshot).

What I can’t explain is why there is no Output Data?

It looks like you are sending the data wrong.

If you look at it you can see that the data underneath body is not a regular object is it some very messed up one of which the most data is the “key”. The easiest way to spot that is that all the data is in one line instead of multiple ones.

You are absolutely right.

After some digging figured out it was an issue with my testing framework. In the Expression editor, I’m able to access those fields by manually referencing them.

That means, I still don’t have the Output Data menu under the Webhook node, and this prevents me to use the IF-node (as it doesn’t accept manual field references apparently).

Should I open another thread for that or can we continue here?

Thank you for your help and support!

We can stay on this topic. But honestly do not understand what you mean. Does simply not make any sense for me right now.

If the data is now correct it should also display it correctly in the Expression Editor. And if you can use an expression in one node it should also work on another one if it is at the same location. Can you please post a new screenshot of the Webhook JSON data and the expression you are using which does not work on the IF-Node.

Sorry for the poor explanation.
This is the data I get, which is properly formatted (this is Webhook-node):

I’d expect data to show up here (this is the IF-node):

This is my workflow currently:

You are using the old key “data” instead of “json” but apart from that does it have to work like that.

So the following two are identical:

{{ $node["Webhook"].data["body"] }}
{{ $node["Webhook"].json["body"] }}

They will however both reference the whole object and are so not great for an IF-Node. No matter what, the expressions above has to work if the workflow is like you described above and the Webhook-Node got executed (so has the small green “1” in the corner). Never experienced that it then does not work. If you look in the Expression-Editor got the Webhook-Node really got executed.

Yes, the workflow gets executed so the data is there, just it doesn’t show up in the Expression-Editor, which in turn prevents me to use the IF-node at all. Typing the expression manually results in the not found message like in the screenshot, thus avoiding me to set it up at all:

I’m using the docker image so not sure if that’s the problem. How could I troubleshoot it?

Does honestly still not make any sense to me unless the “Webhook” node does actually have a different name. Like for example instead of “Webhook” -> "Webhook " (with space at the end) or something like that. But also then the Expression Editor should still work perfectly fine.
Can you please create a video showing the executed workflow, the nodes with their data and the Expression-Editor. Easiest with a tool like loom.

Here is the link: https://www.loom.com/share/b449b787de6a4a0db22a95cad9bb3d64

I’ve progressed slightly: now I can see the Output Data in the Executions. The IF-node seems also to work by just specifying manually the path to the data.

Still can’t visualize it on the workflow editor, which would really help speeding up workflow development.

Ah yes, that can not work. You are looking at a past execution.

You have to copy the Test-Webhook URL, press “Execute Workflow”, do the call to the Test-Webhook within the next 120 seconds and then you will see the data in the workflow and use it.

You can look at this tutorial where it does exactly that. That makes it probably clearer:

Damn, I should’ve watched the intro tutorials. Apologies.

Anyway, tried but seems not working?

Contrary to the video, I’m using a POST webhook instead of a GET. However, I’ve changed to GET and still same result: the workflow gets executed but numbers don’t show up.

You are sending data to the production-webhook instead of the test-webhook. You can see that in the URL as it contains /webhook/ and not /webhook-test/. You can copy the correct one on the Webhook-Node if you click on “Test” underneath “Webhook URLs”.

Oh I see now, tested and it works.

Your support has been great. Appreciate you going over my non-issues and addressed them always with patience.

Thank you!

Great to hear that it works now!

Was a real issue and shows that we have to do a better job in the future explaining how it works in n8n.

Have fun!