Not receiving N8N webhook

Hello!

guys I have a question
i installed a webinar plugin (webinarpress) and i want to capture the data and send it to mautic.

The solution that they advised me was to install N8N in docker in my subdomain and “try” to send the data to mautic through the webhook.

the problem I have is that when doing the test it does not send the webhook

the configuration I did was:

But it doesn’t send the webhook.

But if I go to https://webhook.site/
I copy the webhook test and paste it in webinarpress IF IT SENDS webhook.site the webhook is to say it works.

Let’s see if someone can suggest me something since it is waiting for the webhook and does not receive data.

Thanks

Hi @paolosn, welcome to the community :tada:

But if I go to https://webhook.site/ I copy the webhook test and paste it in webinarpress IF IT SENDS webhook.site the webhook is to say it works.

So this suggests sending data from your plugin works in general, at least to public URLs. I assume your plugin does send POST requests? Does it show any error details when sending data to your Test Webhook URL? Can you POST data to your Test Webhook URL when using another tool (like Postman, Insomnia or curl)?

Hello!
Thanks for the help, I’ve been stuck since yesterday at this point, I’ve been shared flows that work and on my N8N it doesn’t work and it’s frustrating…

Well, I registered as postman and did the following:

I went to the N8N webhook node like in the screenshot above and took the test hook and copied it.

I went to postman and pasted it in post mode

and get this:

{
“code”: 404,
“message”: “The requested webhook “POST b7f02aa2-41d1-4968-bfba-b8539a69b698” is not registered.”,
“hint”: “Click the ‘Execute workflow’ button on the canvas, then try again. (In test mode, the webhook only works for one call after you click this button)”,
“stack”: “ResponseError: The requested webhook “POST b7f02aa2-41d1-4968-bfba-b8539a69b698” is not registered.\n at TestWebhooks.callTestWebhook (/usr/local/lib/node_modules/n8n/dist/src/TestWebhooks.js:25:23)\n at /usr/local/lib/node_modules/n8n/dist/src/Server.js:1664:52\n at Layer.handle [as handle_request] (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/layer.js:95:5)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:144:13)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)”
}

I honestly don’t understand anything, I’m very new to this… but I saw a 404 and associate it with an SSL certificate? maybe my n8n doesn’t have ssl certificate? It’s weird because if I put my link, the lock comes out. Or am I wrong and it has nothing to do with it?

If you wish, I can share my N8N credentials privately so that you can access.
It is installed in a docker on vps contabo.com and I redirect it to my subdomain hosted on webempresa.com and it is assumed that there I have the automatic ssl certificate option activated.

thanks for answering me…

P.S.
this came out on N8N when sending the webhook from postman

Oh, you’d need to manually execute your webhook node by clicking the respective button and also make sure that the HTTP method in your Webhook node and in Postman match:

image

Otherwise your test URL wouldn’t be listening for data.

sorry just before i reply i edited the post
I put in postman post and in n8n post to match.
with which both 5r match (postman and N8N)

I don’t want to claim victory but… this means that you received the webhook, right?
WHAT I DID WAS:

Copy the test url again and paste it in the box to send the test.
I hit the send test button
Below came the sent notice
In N8N, a receipt notice was displayed at the bottom right.

this means that it worked and already receives?

Hey @paolosn, yes, that’s looking good. Is no data shown inside n8n? Could it be that your plugin simply sends empty test webhooks?

yes, it’s just a test, but…

I tried again and now it doesn’t receive anymore…

but in postman it gets those errors again:

{
“code”: 404,
“message”: “The requested webhook “POST b7f02aa2-41d1-4968-bfba-b8539a69b698” is not registered.”,
“hint”: “Click the ‘Execute workflow’ button on the canvas, then try again. (In test mode, the webhook only works for one call after you click this button)”,
“stack”: “ResponseError: The requested webhook “POST b7f02aa2-41d1-4968-bfba-b8539a69b698” is not registered.\n at TestWebhooks.callTestWebhook (/usr/local/lib/node_modules/n8n/dist/src/TestWebhooks.js:25:23)\n at /usr/local/lib/node_modules/n8n/dist/src/Server.js:1664:52\n at Layer.handle [as handle_request] (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/layer.js:95:5)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:144:13)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)\n at next (/usr/local/lib/node_modules/n8n/node_modules/express/lib/router/route.js:138:14)”
}

Could you help me by telling me what all that means?
is there the error?

Thanks for your time and your help.

The error description is pretty telling: Click the ‘Execute workflow’ button on the canvas, then try again. (In test mode, the webhook only works for one call after you click this button)

The test URL only works if you manually execute the workflow before sending data to your test URL.

The production URL on the other hand would be active as long as your workflow is activated, but data send to the production URL doesn’t show up in the canvas immediately as it’s processed in the background.

Check out the documentation on this:

First of all, in the parameters section, we have the Webhook URLs. Clicking on that will reveal the URLs for the webhook. Here you have two options, let’s understand the difference between them.

  1. Webhook URLs
  • Production: A Production webhook is only registered when a workflow has been activated (via the switch on the top right of the page). You will never see its data in the Editor UI. To save the executions, you can either set that as a global default or you can specify that on a per-workflow basis in the workflow settings. You will then see the data from the workflow under ‘Past Executions’.
  • Test: A Test webhook is only registered in the time between executing a workflow via the UI and until the first call gets made (when it displays “waiting for Webhook call”). After the Test webhook gets called for the first time, it displays the data in the Editor UI, and then gets deactivated.

Hello!
First of all, thank you sincerely for your answers, for someone who starts it is of great help since they feel that they are not alone.
Well, I did the following:
I logged out N8N.
I turned connect, open webhook node and in test mode copy the url
I went to the website where I inserted and pasted it, I went back to N8N activated it so that it starts listening, I went to the website where I pasted the url and hit the send test button and the webhook was sent to me. I directed to N8N and the result was N8N waiting and not receiving the webhook test…

I really only received it 1 time and never again…

maybe it only worked 1 time and now it’s “broken”?

I talked to a friend and asked him to do the test for me, in case I’m doing something wrong…

His response was this:

Logged into your n8n and set a webhook node, sent a webhook from my webinarpress. No webhook arrives.

I think this proves issues is with your n8n set up. Try adding an SSL certificate to n8n to see if that helps.

More than this I can’t help with this

so,
the strange thing is that if I access
https://n8n.nogtinailsacademy.com/

I get the padlock that says the SSL certificate is active

Or maybe I see it but from the outside you can’t see it?

Hey @paolosn, the 404 message you are getting when sending a POST request to https://n8n.nogtinailsacademy.com/webhook-test/b7f02aa2-41d1-4968-bfba-b8539a69b698 is coming from n8n, so I don’t think this is related to your SSL setup.

The behaviour you have described is exactly what would happen if you only execute your webhook once manually, but then send more data to the test URL:

Recording 2022-05-31 at 13.51.13

What happens if you activate your workflow through the toggle in the upper right corner of your screen and send data to the production URL instead of the test URL?

image

Hello

switch from test to production.
copy the link.
I pasted it into the webinarpress plugin box and saved the changes
N8N activated

I opened the registration website for the webinar and registered a user and nothing reaches N8N :frowning:

It’s starting to get really frustrating :frowning:

I don’t know what’s wrong.

ok… I did “something” similar to what you do in the video…
but in postman

and the result was the following

I understand that POSTMAN DID SEND THE WEBHOOK TO N8N

it is right?

1 Like

Yeah, that’s looking good :slight_smile:

On the left you can see your request details and on the right you can see the request received by n8n. Though it seems the dummy data {"foo":"bar"} hasn’t reached n8n, I suspect that’s because your have added it on the Tests tab of Postman though rather than added it to the request body.

I do the same procedure but with the web from which I want to send the data and they never arrive :frowning:

I do the same thing again from postman and if they arrive :frowning:

Can I write you privately to send you a screen recording?

So if it works from Postman but not from your plugin I don’t think I’d be able to help very much in all honesty.

One thing I did notice was that your page’s certificate doesn’t seem to be recognised by my browser:

image

This might throw some services off. So in a first step, you could check if there is an option in your plugin to ignore SSL/TLS errors or set up a valid TLS certificate.

If that doesn’t help you might want to check if there’s some kind of log showing error details when submitting the webhook.

Hello
i just did 2 things

activate ssl certificate
and recreate a test flow and it seems to work.

I share the capture so you can see it and tell me if it is correct

thank you.

Can you please update your Product so that whether it is Test or Production, Active or Inactive, you always show the value in the editor window, and that you are always listening, no matter what is going on.

Just like webhook.site.

This will make the job of debugging super easy.