Notion — Error 400 + Webflow to Notion — “Select” fields

Hi guys!

I’m working with a client to connect Webflow forms to Notion (then Telegram). Currently, I’m building a workflow. Webflow’s node works fine, however, Notion’s one doesn’t: I got an Error 400.

What can be the cause of the issue?

Also, is it possible to connect Webflow’s “Select” field in a contact form to Notion’s “Select” (single select) field? I’ve tried but it kinda didn’t work.

Hey @Georgy!

Thank you for creating the post. Two quick questions:

  1. Can you share the Notion template you’re using?
  2. Are the fields in Notion mandatory? Looking at the error message it seems that you have the fields are mandatory and since you’re not providing any information, you get the error.


Also, is it possible to connect Webflow’s “Select” field in a contact form to Notion’s “Select” (single select) field? I’ve tried but it kinda didn’t work.

Can you share more details about this. Do you want to pass on values that the user selects from the Webflow dropdown to Notion?

Hey @harshil1712!

Sorry, my bad — I should’ve attached the screenshots. Here they are:

• Webflow form

• Notion database

• n8n workflow

• n8n — Webflow node

• n8n — Notion node

UPDATE: Somehow I managed to make to enable Notion’s node but I’ve got just this:

What the heck? :frowning:

Mandatory? Is there a way to make fields in Notion mandatory? They are “required” in Webflow’s form though, so it’s impossible to send a message if users don’t fill all the fields. As you can see on the screenshot of the Webflow node, I’ve got all the info.

Sure, here is the select field in the Webflow form.

So my question was related to this select field: is it possible to input the select’s field data in Notion’s select field instead of a text field?

For example, like this:

I’ve tried choosing a select field in Notion instead of a text field but I’ve got this in n8n. It forces me to choose the option — I guess it’s impossible to leave as is if n8n shows this warning sign.


Hey @Georgy,

I was able to replicate your first issue. The error is caused because you have empty fields. Eg. You’re not passing any value for the Email column. If you don’t want to pass a value, delete that property from the node else pass on a value to it. You can’t leave a property empty.

I am taking a look at the Select option and will get back to you on that shortly.

1 Like

Alright, found a workaround for the select option. You have to pass on the ID of the option. You can’t pass the text directly. For this, I would use a Function node to map the ID to the correct label. You can get the ID by using the Get All operation of the Database Page resource. Make sure you toggle, Simple to false.

@RicardoE105, is there any other way this can be handled?

1 Like

Not gonna lie, I didn’t get what you’ve meant: I mean I did map the properties as intended, no?

As I’ve mentioned above, I fixed the issue somehow and the Notion’s node works now but not quite yet:

Maybe I needed to delete all the properties, so I’ve tried that too but I didn’t get anything anyway (I guess it makes sense):

So what should I do with it? Maybe I need to add some stuff in the “Title” field? I really have no idea :frowning:

Damn, sounds a bit (actually, a lot) complicated: could you please create a guide with screenshots or a video? No worries if you cannot — I know that I ask for a lot. I’m just an n8n newbie, actually, it’s my first time using it.

The issue it’s that you are not referencing the data from the Webflow Trigger in the Notion node. For that, you need to use expressions.

1 Like

I created a test workflow that adds data to a table in Notion. The table contains Name, Email, and Org fields. I use the Notion node to add this information and create a new entry in the table. In my test, when I entered only the Name field it worked as expected. If I added the Name field and Email field but didn’t add any value in the corresponding Text field, I got an error similar to yours. However, if I add values to these Text fields the data got added. I hope this simplifies. If not, let me know.

I will try to create a small video and an example workflow that might help. In the meantime, you can try this out:

  1. Get the label IDs as mentioned above.
  2. Use the Switch node to check for the incoming label from the Webflow Trigger node. For example, if the incoming label is To Do, route to the 0 output.
  3. Add the Notion nodes to the output of the Switch node. Eg. If the label is To Do, connect a Notion node that adds the To Do label. This way you don’t have to dynamically add the label.

This is a workaround and has drawbacks. But for the time being, it is a good solution to keep going :slight_smile:

1 Like

Thanks a lot, @RicardoE105 and @harshil1712!

I’ve realized what I was doing wrong after @RicardoE105’s message: I didn’t use expressions to get the data from the Webflow’s node.

As for, your, @harshil1712’s message: I guess you were explaining how to make select fields work in n8n. If so, then I’m gonna try it!

That being said, I have two questions:

• What are the drawbacks of your method, @harshil1712?

• Is it a normal behavior when I can’t see all the information in the node’s settings but I get the actual data in the end?

Here are the screenshots:

As you can see, the Notion’s node didn’t show all the data from the Webflow’s trigger for some reason, so I wonder if it is intended behavior.

@harshil1712, man! Thanks a lot! I’ve learnt a lot today!

It works! Now I see the drawbacks of this method.

That being said, guys, @harshil1712, @RicardoE105, sorry for my stupid questions: I am really against deep-diving into the software/tools/app/games/etc when one’s didn’t even complete most basic tutorials — I did not do so today because I just wanted to make it work ASAP. I’m really sorry for that! :frowning:

Well, guys, I hope you don’t mind another silly question: how to make the workflow work all the time? It just works once and only when I click on “Execute workflow”. I did click on “Active” switch.

1 Like

The workflow works all the time when it’s active. You can see when the workflow is executed if you go to the executions menu options.

1 Like

Yes, you are right! I just deleted/stopped “Execute workflow” thing, switched off and then switched on the “Active” thing and now it works automatically but… there is another “but”:

For some reason, the data triples! I didn’t change anything in the nodes.

EDIT: Here is the screenshot of the Switch node.

EDIT: I really have no clue why the cloning happens. It didn’t happen when I turned off “Active” and tried “Execute workflow” once: it’s a field in Notion with “Georgy” and “Wanna create a cool game?”. Afterward, I thought that it’s okay and turned on “Active” again but…

…the duplicating thing happened again.

Hey @Georgy,

There’s no such thing as silly questions :wink:

Looking at your screenshot, it seems like you’re not referencing the value in the Switch node correctly. Are you getting any value returned for the Value 1 field?

1 Like

I found out what caused the duplication thing — hilarious! :smiley:

I deleted three of them and now it works as smooth as butter!

1 Like

I’ve got a better solution!

Gonna make a video tutorial and post it here and as an additional post so stay tuned :sunglasses:


That’s awesome! Looking forward to it :slight_smile:

1 Like

Hi ! Is the video tutorial available ? I was facing the same problems ! :slight_smile:

You can subscribe to my Telegram channel for the news about the video tutorial→

1 Like