Notion Generic Header Auth Issues

The Notion API spits an error that I am using the wrong version of the API if I use the preconfigured authentication type.

From this post (HTTP error on Notion API after updating N8N), I saw the solution was to use a generic header.

I tried that and get this error.

I really have no idea what it want’s me to do, my https request follows a format that I’ve used with the Notion API in the past.

Hey @Greg_Hadley,

If you wanted to specify a new version of the notion api using the HTTP Request node using the predefined credentials won’t work at the moment you would have to create generic credentials to use it. If you are using a generic credential did you use Oauth?

I didn’t use oauth because that’s only for their public intergrations and requires me to post a terms of service link and other things. I just wanted to use internal integration.

Hey @Greg_Hadley,

The error looks like they are wanting oauth or something. Have you moved to a generic header auth option?

really confused here. None of the authentication methods seem to work, whether generic or one of the 2 predefined credentials.

Hi @Greg_Hadley,

When you use predefined are you using Access Token or OAuth and the same with Generic I guess is that using header auth or OAuth?

What you can’t do with the predefined credentials is set a header for the version, Can you share the request you are trying to make?

For me this request is working.


If I then do the same API call with a Generic Auth header I get the same result back.

The only difference is when using Generic Header Auth I have to set the Notion-Version header as well.