OAuth 2.0 Error 404 ASANA Connection

Hey everyone,

I’m running into an issue I can’t seem to find any help on when it comes to online documentation for errors or forums so I’m hoping someone here might have the time to help or at least steer me in the right direction.

So I have a self-hosted N8N installation on a Linux Debian 11 Virtual machine being powered by ESXI 7.0 Free edition. I have setup my N8N install using docker on this system and it runs great. I have connected several apps to it including Google drive and Google sheets along with their OAuth 2.0 credentials and API’s as well as a few others so I’m fairly certain I know how to do it right at this point but I’m getting an odd error when connecting to ASANA.

So I have followed the ASANA OAuth 2.0 Direction Here and for some reason it is not working. The only difference I noticed from the directions is on the developers menu for creating an app, the directions make it seem like the App Name, App Short Description, Client ID and Secret Key is all on the same page as the Redirect URL’s. On my version of ASANA (I’m not sure if there are different versions) in the developers section, when I create a new app, I get everything mentioned on a single screen except the OAuth Redirect URL. On the left hand menu there are 3 main sections. One is basic settings where I enter most of the info, OAuth where the client ID and Client Secret Key from the basic settings page are also listed but also the Redirect URL options are listed here as well and finally the App components section.

Now I have setup the OAuth with Client ID, Secret Key and the Redirect URL from N8N self hosted system as well as entered the corresponding info into N8N Asana OAuth2 API Credential. My problem is that when I click connect in the N8N installation, I get the “Are you sure you want to allow this…” pop-up window and I click Allow but then I get a black screen in that pop-up window that has the number 404 in white small text in the top left corner.

At first I thought that I had copied a credential wrong or somehow lost a character in the copy/paste process so I went back and made sure they matched exactly then retried it only to get the same error. I’ll be the first to say that I’m not a developer but I think I have a pretty good handle on OAuth credentials. I mean they are basically 3 components.

The only thing I’m not sure on is when I go back to my ASANA “My Apps” section in the Developer window, the N8N OAuth 2.0 Application I made in ASANA has a small bit of grey text under it that says “In Development”. I’m not sure if that means it’s not activated for me to use or what but I would assume it should work so you can “develop it” like it implies before publishing it to the ASANA app marketplace.

I’m not sure why it doesn’t work or what’s going on with the fact that it asks me to Deny/Allow the connection and then goes to a 404 page but I’m assuming I have missed a step that is not detailed in the instructions I used or something has changed to make this integration not work anymore.

Any and all help would be greatly appreciated. I thank you in advance!

Hey @kgrdl123,

Looking at that error message my first thought is the redirect url is wrong, it might be worth double checking it to see if it is the correct value and if following it still works.

The only other thing I can think of is checking the url is it loading when you get the 404 to see if we are adding anything to it or if Asana is.


So I went back and checked it and noticed that the ASANA Redirect URL is the same exact URL as my Google API/Google Sheets API Redirect URL for my Google Credentials. I’m not sure if they are supposed to be different or not but I figured it would be worth mentioning.

When I copy the redirect URL from the ASANA credentials or any of the other credentials and paste it into chrome browser it takes me to the same 404 page but my google credentials still work.


I should be more clear on that last part. When I copy the ASANA or Google Redirect URL from n8n (Both of which are the same URL for both credentials) into a browser window I still get the same 404 page as when attempting to allow the connection to ASANA but my n8n Google credentials that I allowed a couple days ago still work in n8n even though the redirect page does not.

Are you using n8n with your own domain or with the tunnel option? It could be worth restarting n8n and checking the url we show in the credential, if you are using tunnel it can change.

What version of n8n are you currently using?

1 Like


Lookslike it was a matter of restarting N8N, then docker and then the VM that all of it was hosted on. If I do it in that order it works and changes the Webhook URL. If I only do one or 2 of those, for some reason it doesn’t. And to my surprise, even going straight to restarting the VM doesn’t work. It took me several hours of restarting and scratching my head before I finally decided to try to restart everything in that order and then it worked.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.