OAuth Callback URL is localhost:5678

Hey @farhan_Y,

They webhook_url should be that should sort it out although some services won’t let you use an IP / HTTP so you may need to think about getting a domain if you see any other issues.

Hey @Jon ,

So I need to change my “” into domain name right?
Then I need to “export WEBHOOK_URL=https://n8n.example.com/” like this right?

Hey @farhan_Y,

In theory using should work but it looks like it isn’t set properly, If you ran into issues with an oauth service you could then swap to your domain instead.

Thank you @Jon ,
I solve by run the server locally by using Remote Desktop Connection.

1 Like

I ran an n8n container from Docker Hub, without realizing I had to set the environment variables during the docker run command. It would have been incredibly helpful to have something in the n8n container logs that indicated setup was incomplete, or have the option to configure this after the fact.

Now I have to recreate my container, so I can set the environment variables.

Hey @trevor,

Welcome to the community :raised_hands:

Using localhost can be a valid option depending on what you are using n8n for but I agree it would be handy to maybe have a prompt when you first login to say the setup may not be complete.

1 Like

True, I didn’t think about that. Thanks for the welcome and the awesome software! :slight_smile:

1 Like

No problem, enjoy working on your automations and interacting with the community.