OAuth redirect times out

Hi, I try to add a Google Oauth Credentials for google sheets. after I click on Sign In with Google I can choose the Google account, I can select the permissions but after the LogIn pop up should redirect to oauth.n8n.cloud I get an ERR_CONNECTION_TIMED_OUT

Any ideas?
Thank you

Hi @pfiadDi, welcome to the community

I am so sorry you are having trouble. Are you seeing the timeout on the https://oauth.n8n.cloud/ URL itself? These URLs opens quite fast for me actually when testing this just now.

Is there any chance this could be a network problem? Would you perhaps be able to test this on a different network, just to be sure (for example your mobile network instead of the office wifi)?

Hi, even the normal URL timed out on my computer - that made me wonder. So I tried to use a VPN and it worked. There seems to be a problem with my ISP.
Thank you for your help


Glad to hear it’s working for you via VPN. Still sounds strange, do you mind sharing your ISP and the region you’re in with me (feel free to DM me if you don’t want to post publicly)?

This is just for me to check if there are any known connectivity issues with the MS Azure data centre (where the n8n cloud infrastructure is hosted).

Thank you; I sent you am DM

1 Like

Thank you so much @pfiadDi (great username btw :smiley:), I shall take a closer look into this tomorrow morning!

Just wanted to post a quick update on this one. I do not have access to the affected network, but have tried a bunch of geographically close networks without being able to reproduce the problem. I’ve suggested filing a report with Azure here for a closer look from their end. I’ll get back to you as soon as I hear anything.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.