OAuth Redirect URL stuck as local host on render

QAuth redirect URL remains http://localhost:5678/rest/oauth2-credential/callback when I need it to show my render URL so I can connect to Google accounts. I’m still new so please forgive noob question and probably lack of info.

Error message:

This site can’t be reached

localhost refused to connect.

I’m using Render and Supabase to run N8N off cloud.
I have added WEBHOOK_URL - https://MYURLonrender.com
I have tried to connect googles sheets to N8N workflow but it seems like it will only show localhost.
Goal is to connect google sheets with google cloud credentials. Have been through docs carefully and pinpointed localhost to probably be the issue.


## Share the output returned by the last node
ERROR: Unable to sign without access token

## Information on your n8n setup
- **n8n version:** latest
- **Database (default: SQLite):**  (Supabase?)
- **n8n EXECUTIONS_PROCESS setting (default: own, main):**
- **Running n8n via (Render - Supabase
- *Windows

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

hello @jakeThai

the WEBHOOK_URL env should do the job. Are you sure the env has been set? You can check it with the webhook trigger node, it should contain the proper address.