OAuth2 callback issue with Slack app

Hi all,

I get a similar issue than pinpointed in this thread - now closed.
I’m trying to make an app in Slack, able to send /commands to trigger n8n workflows, and simply send messages in Slack from workflows.
I chose to make an app for that, with OAuth authentification as a credential in n8n.

As I understand it, the call back expects a “state” from the Slack app. Not sure what to do here and if someone has seen a similar issue.

Thanks in advance for your input.

n8n version: 1.22.5
Selfhosted, Docker

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @maxfav,

It sounds like the Slack app has not been configured correctly, Normally the OAuth option is pretty good and everything just works. Are you using the Slack credential or are you making your own generic oauth2 credential?

Thanks for the feedback @Jon
I did use the same URL on both sides, using the official credential. As you see on the screenshot, the connection’s alright, yet the app did not install.

By fiddling around in the app, I managed to install the app in Slack without the issue since, without the OAuth workflow. And it asks to reinstall via that workflow.

But, I still can’t do the /commands that I setup in the app. I believe that this would be a fantastic way to trigger various workflows in n8n. This might be due to the non-OAuth workflow installation.

I did an ugly workaround using “Push to Zapier” to get a call from a Slack message and forward it to n8n.
Let see if there are some other experiences around with those apps.

Max

As a side note, I’m not a tech guy, so lot’s of trial&error around :slight_smile:

**

**