OneSimpleAPI website image refresh not getting a new image

Hi,
I am using the OneSimpleAPI node to get a screenshot of a website before and after applying updates (Wordpress updates).

I have made sure the “Force Refresh” option is enable to make the API return a fresh image of the website (not a cached or stored image) but it returns the same image, before and after.

Anyone else seen this problem? Should I just use the url (as detailed in OneSimpleAPI tutorials)?

Here is the workflow step (I can share the whole workflow but not sure if it is relevant). The second screenshot is a duplicate of this one.

Information on your n8n setup

  • n8n version:0.193.3
  • Database you’re using (default: SQLite):SQLite
  • Running n8n with the execution process [own(default), main]:
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]:Docker

Hi @PaulBR1, the n8n node would simply send an HTTP request to the service, so I am not entirely sure if One Simple API not catching a website update would a problem with n8n. I know @Jon built the node because he used their service a lot a while back, perhaps he can help out with this one?

1 Like

Hey @PaulBR1

I have just taken a quick look and it looks like I am not able the get a refreshed image using CURL either, I have dropped a message to the chap that runs OneSimpleAPI to see if it is a known issue with the service or if I am doing something wrong.

1 Like

Thanks @MutedJam and @Jon for your help.

Hey @PaulBR1,

I tagged you in the OneSimpleAPI community Discord about this one, It looks like the CDN being used will cache the result for an hour so that could be the issue you are seeing.

1 Like