OpenAI is 404 with models gpt-3.5-turbo and gtp-3.5-turbo-0301

This is the error:

NodeApiError: The resource you are requesting could not be found
    at RoutingNode.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/RoutingNode.js:112:23)
    at runMicrotasks (<anonymous>)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
    at Workflow.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/Workflow.js:694:23)
    at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/WorkflowExecute.js:590:53

Did anybody experience the same issue?

Hi @artildo, perhaps you can fill out the full question template when posting on the forum going forward? I feel like the version of n8n you’re using would be vital information here seeing the node has changed quite a bit recently.

From giving this a quick go on my end I am too encountering this problem and will add this to our bug tracker for a closer look and fix. We’ll update the thread once the fix is available.

I will get this one sorted, The issue is where we load all the models available from OpenAI but not all the models work with Text Complete.

For Text Complete the supported models at the moment are…

text-davinci-003, text-davinci-002, text-curie-001, text-babbage-001, text-ada-001, davinci, curie, babbage, ada

If you wanted to use the GPT options you would need to use Chat > Complete which supports…

gpt-4, gpt-4-0314, gpt-4-32k, gpt-4-32k-0314, gpt-3.5-turbo, gpt-3.5-turbo-0301

These can be found here: OpenAI API if needed.

2 Likes

Thank you, @MutedJam and @Jon . The mode matters, chat is working.

2 Likes

you are the best, jon!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.