Persistent and reproduceable UI BUG that is bugging me a lot

Describe the issue/error/question

EVERY time you create a new workflow or change it - you cant run it
See the video here

This has been going on for the past few versions now.

What is the error message (if any)?

The workflow just appears to be running BUT doesnt run at all - indefinitely. You cant stop it (gives and error message about cant stop).
The only solution is

  1. Save the workflow
  2. Refresh the page
  3. Then if you do what you did previously that didnt work - it just works now !

Getting tired of this drill now as you start to build 100 workflows and keep changing them, so I thought I would bring it up.

Please share the workflow

(Select the nodes and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow respectively)

Share the output returned by the last node

Information on your n8n setup

  • **n8n version:0.205.0 and earlier too
  • Database you’re using (default: SQLite):
  • Running n8n with the execution process [own(default), main]:
  • **Running n8n via [Docker, npm,, desktop app]:docker

Has no one seen this at all?
I see it 50 times a day !

Yes, I’m experiencing the same (same n8n setup).

Thanks - I was about to wonder if I am just crazy !
Is this any browser?
I use Edge most of the time so not sure if it is browser related.

Actually, the workflow is running but I can’t see it running or its results in the UI. Always have to save and refresh, then execute.

@treyr can you confirm if this is fixed in latest version? I believe I saw a fix for this slated to go out with 0.206.1.

1 Like

Actually, the latest version is 0.207.0 so best to test with that one.

1 Like

@maxT I can confirm it’s still (kinda) there (just updated to 0.207.0). When I click “Execute Workflow” the On clicking ‘execute’ node says “Waiting for you to create an event in Manual” - you can’t see the workflow running.
When saving of manual executions is enabled and I hit the stop button, I can see the workflow executed and I can examine nodes and outputs.
When saving of manual executions is not enabled and I hit the stop button, it says “Problem stopping execution, Execution not found”.

Thanks @maxT for the attention to this - I am going crazy with this.
I will update to 0.207 on a test instance and check - will report back.
In my case the workflow doesnt run - it doesnt run, stop - nothing and save+refresh is the only answer

@maxT Sorry to report 0.207 still there

Infinite executing and not stopping - all it takes is two nodes (as I just did) on a new workflow to reproduce this error

@treyr When you replace the GET HTTP with something that creates a record, row, contact (or anything else really) you’ll see the record is created so the workflow actually gets executed. We just can’t see it in the Editor UI.

@antitalent - thanks - I dont think I have added or changed data so havent seen it - will test that out too.
I just now - create workflow - save - refresh - run - save, refresh - run …


Out of interest are you using nginx as a reverse proxy?

No @Jon - standard docker config that used caddy

Hey @treyr, I tried to reproduce your error but was not able to (tested in a few different versions). Does this happen every time for you? Or just under specific conditions?

@Niklas_Hatje it happens every time.
I believe I have a video attached initially on how easy it is to reproduce.

Yep, saw the video but was not able to reproduce at first. I managed to reproduce it by now (by throttling my internet speed). Thanks so much for finding and posting this!

@Niklas_Hatje - thanks.
I dont think my issue is internet speed related though
Have a 1Gbps connection and the server is on DigitalOcean and speeds are consistently > 500 Mbps between the browser and the server.
But I am glad you can reproduce this.
It may be related to the speed at which I create and execute nodes? I do it very fast.

Hey @treyr, how is your docker configured? Is it using docker-compose? I’m seeing this exact same issue on my production instance of N8N that uses docker compose and postgresql/traefik. But a local test server I just deployed using just straight docker/sqlite doesn’t encounter this issue using the exact same workflow. Might be worth while comparing environments to see if there is something in the configuration that can be duplicated to introduce the issue.

@cleveradmin I pretty much use the default docker instance with docker-compose.yml and sqlite on a brand new droplet
All current apt patches, docker and n8n versions.
This has been and continues to be a problem for me with every update from every browser.

Maybe a local vs internet issue - can you copy the local to an internet host?