Pinecone Vector Store - No result for index list

I am using the n8n cloud implementation. I have a workflow that is trying to use Pinecone Vector Store to insert records in an existing, empty index in my Pinecone account.

When I attempt to configure the Pinecone Vector Store and select my index from the dropdown, there is no result of indexes to pick from.

Any thoughts on what I might be missing? Thanks!



  • n8n version: cloud
  • Database N/A
  • n8n EXECUTIONS_PROCESS setting N/A
  • Running n8n via n8n cloud,
  • Operating system N/A

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Any thoughts on this issue? Could it be the difference between using the serverless approach with Pinecone instead of the Pod index approach.

I noticed that there is an Environment value in the n8n.io Pinecone credential screen that is prefilled that points to a gcp instance. The Serverless version of Pinecone is only on AWS at the moment.

image

Hi @Steve_Stava :wave: Welcome to the community :tada:

That second post may indeed contain a hint as to fixing this for you - it looks like all of their indexes are here: https://docs.pinecone.io/docs/indexes#serverless-indexes

Would you by chance be on us-east-1-aws and if so, does changing this fix this up for you?

Thanks! I tried the following combinations: (nothing worked, yet…any ideas? :slight_smile: )

  1. Changed the environment value in the credentials for pinecone to “us-east-1-aws”. It verified but didn’t list any indexes in the Pinecone component in my workflow

  2. I tried the serverless environment of “us-west-2” in my credentials and it wouldn’t verify. The documentation says that the serverless environment is only available on us-west-2 for now.

  1. I tried calling the list index api via curl and was able to see the index in the response (see below). The interesting part is that the serverless index doesn’t have an “environment” property in the api response…the pod indexes do have “environment” in the response (see example below)

Serverless index curl response

{"indexes":[{"name":"n8n-letsweb3-gmail","metric":"cosine","dimension":1536,"status":{"ready":true,"state":"Ready"},"host":"n8n-letsweb3-gmail-0mhtlf3.svc.apw5-4e34-81fa.pinecone.io","spec":{"serverless":{"region":"us-west-2","cloud":"aws"}}}]}

Example pod index curl response

{
    "name": "pod-index",
    "metric": "cosine",
    "dimension": 1536,
    "status": {
        "ready": true,
        "state": "Ready"
    },
    "host": "pod-index-4zo0ijk.svc.us-west2-aws.pinecone.io",
    "spec": {
        "pod": {
            "replicas": 1,
            "shards": 1,
            "pods": 1,
            "pod_type": "p1.x1",
            "environment": "us-west2-aws"
        }
    }
}

change enviroment to “gcp-starter”

Thanks @igordisco! My pinecone account was using their Serverless index (newer option).

I had to delete that index and create a Starter Index. At that point it works with the gcp-starter option for the environment. (Thanks!)

From what I can tell, the n8n Pinecone component does not support the new Pinecone serverless index option :cry: This is the opiton that is 50X cheaper than having a Pod based index.