Possible Airtable bug when creating Attachment record

I’m using an Airtable node to create records in Airtable. All the fields are created correctly, apart from the fields where I’m trying to upload an Attachment. When I try to add the attachment it fails.

The attachment field is set correctly in Airtable, including the name.

I believe my json is correct and that there might be a bug in n8n / Airtable.

The error I get is:

ERROR: Invalid input for ‘Logo’ [item 0]
‘Logo’ expects a object but we got ‘[object Object]’.

Here’s the JSON data relating to just the part that is failing:







According to Airtable’s docs this is the correct way to upload attachments.

Could it be a bug with the Airtable node? I noticed it was just recently updated?

Share the output returned by the last node

Information on your n8n setup

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (desktop app):
  • Operating system: MacOS

Hi @Vanja :wave: Welcome to the community :tada:

Could you share your workflow, as well? If you hit cmd/ctrl + a and then cmd/ctrl + c, you can then paste over your workflow here. Placing it between two sets of three backticks (```) would be perfect!

Also have you tried to use the Airtable node for this before and were successful, or are you new to n8n?

One more reply here, @Vanja - this can be a workaround for you in the meantime:

1 Like

Yeah I did run it successfully, last Thursday it was working. The next day it failed. The only thing that changed was I reloaded my airtable inside the node (I was adding a new column and needed it to appear in the dropdown).

Nothing else changed.

Here’s the flow. All works up until the Airtable node.

I tried using a HTTP request node too. That worked for uploading the attachment but fails on something else! (/n new line character in one of the text fields causes a 422 issue). The /n in the text field posts to airtable via the airtable node though. So frustrating.

A fix for either would be awesome! Appreciate it.

That definitely doesn’t sound right if that was all that was changed :thinking: I’ll flag this with our developers to take a closer look, and will be back with updates once I have them! In the meantime, that workaround above should be a temporary fix for you :+1:

ok got it working with your suggestion.

Thanks for the help!

1 Like

Hey @Vanja,

Between it working and the table being refreshed did anything anything change either with your n8n version or in your Airtable base?

No I don’t think so.

A day or two before I updated n8n itself, and I noticed there was a new version of the airtable node which I swapped to.

But can’t think of anything else between the day it was working and the next day when it stopped.

Interesting, Thanks for the info. I was looking into it and I can’t see any way for it to have worked in the current version so I suspect there could be a bit more to this but we will get this fixed.

Also facing this issue, and I’ve tried many combinations of format and file. Trying to add an attachment to Airtable using the public URL of an image or video.

Using a test url with all other parameters trimmed out: This works for me on other platforms so was surprised it was erroring out.

{{ [{url:‘https://www.filepicker.io/api/file/5YTJXioCQG0tYWPw6OPw’}] }}

Output: [Array: [{“url”: “https://www.filepicker.io/api/file/5YTJXioCQG0tYWPw6OPw”}]]

Gets me error: ERROR: Invalid input for ‘Profile Pic’ [item 0]
‘Profile Pic’ expects a object but we got ‘[object Object]’.

So I tried:

{{ {url:‘https://www.filepicker.io/api/file/5YTJXioCQG0tYWPw6OPw’} }}

Output: [Object: {“url”: “https://www.filepicker.io/api/file/5YTJXioCQG0tYWPw6OPw”}]

Gets me error: 422 - {“error”:{“type”:“INVALID_ATTACHMENT_OBJECT”,

@Vanja is this currently working for you?

Hey @alexiom,

Currently it looks like saving an attachment isn’t working, We are tracking this internally as NODE-717 and will post here once this is fixed.

1 Like

I haven’t tried it since, but managed to get it working using the approach suggested by EmeraldHerald at the start of the post.

I’m also getting exactly the same issue. :slightly_frowning_face:

@Jon do you have a rough ETA for a fix? My current workflow relies on uploading attachments to Airtable.

Hey @EnigmaXXIII,

No ETA at the moment for this one sadly.

@Jon :sob: do you know if a workaround that works? I tried the suggestion by @EmeraldHerald above, but cannot seem to get it to work either.

Hey @EnigmaXXIII,

The only thing I can think of would be to use the HTTP Request node to manuallly send the data which should work if you follow the API docs from Airtable.

I don’t know if this aids the debugging process. But if you copy and paste the Airtable node into a text editor. The issue seems to be because n8n appends two \ characters to the expression mapping for some reason.

        "columns": {
          "mappingMode": "defineBelow",
          "value": {
            "Name": "={{ $json.name }}",
            "id": "={{ $json.id }}",
            "Splash": "={{ {\"url\":$json.splash} }}",
            "Icon": "={{ {\"url\":$json.icon} }}"

Hey @peterng1618,

The issue itself seems to be around the resource component and how the internal mapping happens :slight_smile:

This is genuinely the most frustrating issue as it’s preventing my entire build from working properly. I intentionally moved over from Make (Integromat) for greater functionality, but is so annoying that uploading files to a record just isn’t possible. :sob: :sob:

I have the same issue, annoying yes but not as annoying as reciving those dam Make.com invoices for half of your retirement fund every month :wink: