Possible bug with Postgres node

When I’m using postgres node insert mode with map manually, on the field containing emails Im getting this error:

Invalid input for 'private_mail' [item 0]
'private_mail' expects one of the following values: [] but we got '[email protected]'

I think it’s couse I’m using custom datatype for this column couse of the stack trace top most part:
Btw. everything works when postgres node is switched to map automatically (tested with the same custom type, but diffrent workflow and use case situation). Any ideas how I can overcome it? Mapping keys of the data to those of table colums will take a while.
ExpressionError: Invalid input for 'private_mail' [item 0] at validateValueAgainstSchema (/usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/NodeExecuteFunctions.js:1512:15)

Information on your n8n setup

  • **n8n version:**1.44.1
  • **Database (default: SQLite):**PostgreSQL
  • **n8n EXECUTIONS_PROCESS setting (default: own, main):**own
  • **Running n8n via (Docker, npm, n8n cloud, desktop app):**docker

Welcome to the community @Filip_Reszke :tada:

How is the custom data type private_mail defined in your PostgreSQL setup? Could you also maybe share your workflow or parts of it here by copy & pasting the workflow JSON content in between two block quotes (```)?

Hi! Sorry I won’t be able to share this workflow since it has been rewritten already by my collegue. We define this custom data type as it follows CREATE DOMAIN email AS citext CHECK ( value ~ '<looong regex>');