POST Webhook in https

Hi everyone!

My n8n installation is working fine with all the webhooks in http.
In order to make some improvements i am trying to use HTTPS.

For now, my webhooks URL looks like http://{{domain_name}}/webhook/…
I would like to change it to https://{{domain_name}}/webhook/…

I am using docker to launch n8n and an set up the following parameter :
-e N8N_HOST=“domain_name” -e VUE_APP_URL_BASE_API=“https://domain_name/” -e WEBHOOK_TUNNEL_URL=“https://domain_name/”

The issue is that my last POST Webhook is still in http. So the request is blocked by Firefox.
The error message is like : The information entered will be transmitted in clear (without encryption). They can therefore possibly be intercepted and read during their routing.
Are you sure you want to send this information?

But even if yes is clicked, no information is send…
Do you have any clue on this one?

Thx by advance!

I add WEBHOOK_URL=“https://domain_name/” in my launch docker command.
Now the error is :

code 404
message ‘The requested webhook POST …/webhook/… is not registered.’

But i sware it is registered!

Is there something like WEBHOOK_URL_POST to set up?

but now i have the following firefox error :


Hey @herrT15,

To use HTTPS you would need to set WEBHOOK_URL to your full url and make sure that you have your SSL certificate configured on your reverse proxy in the normal way.

1 Like

Thanks almost ok on my side.
I forget to tell something.
In my worflow I add an http request node. when it is active my https workflow is not working but when it is disable my https workflow is working fine…
I tried to modify the URL in the http request node in http or https but still do not work…strange…

Hey @herrT15,

Can you share the workflow?

It is something like :

So I might be lost here but what is the actual error you see when running that workflow?

The results of the GET Http request is never downloaded

is there an error on that node in the execution log?

One point for you.

“connect ETIMEDOUT”,
“Error: connect ETIMEDOUT at TCPConnectWrap.afterConnect [as oncomplete] (node:net:1494:16) at TCPConnectWrap.callbackTrampoline (node:internal/async_hooks:130:17)”,

But curl is ok

Firewall issue!!!

All is ok
Jon thanks a lot


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.