POSTGRES ERROR: Connection pool of the database object has been destroyed

He managed to replicate today, check it out here.

Hey @MayurVirkar,

I did indeed as mentioned above, Are you only seeing the issue when running multiple queries or just one?

One query, but when its run in parallel with some other background workflow.

meaning, when I run the workflow (single item execution) when nothing is running in the background, then everything is fine.

But when I run the same workflow when something is running in the background, i get the above error.

I couldn’t get it to fail when I tried one query with background running queries as well for me it took a lot of data.

Are you using a standard Postgres docker image or something else?


Standard docker image.

By reducing the number of parallel executions, we could reduce the failure rate.
First it was 2/3 now its 1/3

@MayurVirkar for your setup it could be worth tweaking the config of Postgres but we will know more once someone picks up the dev ticket.

@Jon How can I track the progress of this issue resolution?

Hey @alexandre.iramos,

Welcome to the community :tada:

You can keep an eye on the GitHub PRs or this thread, Once we have popped the PR in and released a fix there will be a message posted here.

1 Like

Fix can be found in the PR below which will be released soon.


New version [email protected] got released which includes the GitHub PR 7074.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.