Postgres Node Select 403 error from hosted domain, but no problem in localhost

Describe the problem/error/question

My n8n is hosted using IIS reverse proxy, but it behaves a bit weird. e.g i used a Postgres Node, and provided credentials. all modes except Select can access the schema and tables, but when i used Select, it gives error message ‘Could not load List, Please check your credentials’

When i tried to access directly in the server using localhost:5678, there’s no problem to use the Select mode on postgres node. so my sense it must be something wrong in IIS proxy server

I have followed the installation process in the tutorial. is there anyone who have faced the same issue? is there any solution for this? or would spawning a new ec2 instance in aws will be a quicker and easier fix?

What is the error message (if any)?

‘Could not load List, Please check your credentials’

Please share your workflow

Information on your n8n setup

  • n8n version: 1.7.1
  • Database (default: SQLite): Postgres
  • n8n EXECUTIONS_PROCESS setting (default: own, main): default
  • Running n8n via (Docker, npm, n8n cloud, desktop app): npm
  • Operating system: Windows

Hey @felix_richard,

Welcome to the community :raised_hands:

Looking at your description I would agree it looks like an issue with the IIS setup. Sadly though I have not touched IIS for a few years so I am not sure where to really start on that one. A quick test could be to set the N8N_PUSH_BACKEND environment variable in n8n to sse and see if that works if that solves it the issue will likely be around websockets and it will be a case of digging through the IIS / ARR module to see what needs to be set to allow that.

1 Like

after wrecking my head for several days, apparently the problem because of Cloudflare.
I directly call the failing endpoint in browser, it faced the Cloudflare challenge. after finishing the challenge I am now able to get the list of schema and tables for Select in Postgres node.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.