Preconditions check failed only when calling workflow via webhook

Describe the problem/error/question

When I run a workflow that uses the GMail API from the Editor it works perfectly. Now I need to run the workflow from another workflow, which I am doing via a webhook call. That fails, with the error being “precondition check failed” which has been mentioned by many others here.

I’ve checked running the workflow with the exact same input parameters via the Editor as was called from the other workflow.

Is there some difference in how the Credentials module is being used when in the Editor vs when workflow being called from another place?

What is the error message (if any)?

400 precondition check failed

Information on your n8n setup

  • n8n version: 1.16.0 Cloud

Hi @revhuntr, I am sorry you’re having trouble though I am not quite sure I fully understand the problem. Can you share an example workflow that cannot be called via webhook on your end?

I tried setting up the below workflow:

This can however be called from another workflow through the HTTP Request node just fine. So it’d be great if you could share a reproducible example here.

Thank you!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.