Problem in node ‘OpenAI‘ Cannot read properties of undefined (reading 'isAxiosError')

I try to run an OPENAI node, and this error appears, does anyone know why this could be happening?

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Welcome to the community @Martin_Lopez!

Can you please share your node as I just tried and I can not reproduce it. Thanks!

1 Like

Yes

Works totally fine for me. As you did not fill our template and instead just deleted it, I assume you are probably on an old version which contains some kind of bug. Please update your n8n version and then try again.

I am Running n8n via n8n cloud. I just updated to version: [email protected], but the workflow still doesn’t work :frowning:

I don’t know what could really be wrong.

I get this error:
ERROR: Cannot read properties of undefined (reading ‘isAxiosError’)

Details:

TypeError: Cannot read properties of undefined (reading ‘isAxiosError’)
at RoutingNode.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/RoutingNode.js:122:44)
at processTicksAndRejections (node:internal/process/task_queues:95:5)
at Workflow.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/Workflow.js:733:23)
at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/WorkflowExecute.js:656:53

Hi @jan,

Using latest Docker image, I also currently encounter with the same error randomly. When I re-run the workflow with the same data, it works after a while. I am not able to reproduce the issue, can’t see any log to inform you or fix and contribute to community :expressionless:

@jan
I already found out what it was! I needed to add credits to my OPENAI API usage.

I added credits and everything is now working fine.

Thank you very much for your attention.

That is great to hear @Martin_Lopez! Thanks for writing your solution here. But still seems like a bug as then still instead of this error message the actual error from the API should have been returned.

Have the same problem with the latest n8n version. Must be some kind of bug. I have credits on my OpenAI, but still doesn’t work. Please notify me if you found the solution.

We are already in the middle of fixing it:

I am also trying to use the OpenAI integration to execute my workflow, but I get still the same error: ERROR: Cannot read properties of undefined (reading ‘isAxiosError’)

I have updated n8n to the latest possible version on docker and checked all my settings. So what can I fix

Hi I’m getting the same error today 1/8/23 (but yesterday it was working great with no issues)

ERROR: Cannot read properties of undefined (reading ‘isAxiosError’)

has the issue been fixed?

i’m also experiencing this error, has there been a fix yet?

Hi,

The github issue is reported to have been fixed in 1.24.
I face the same error a few minutes ago, updated my instance from 1.22 to 1.24, and isAxiosError was gone! The same workflow then errored with “your input has 10k tokens while max is 8192”, which is way friendlier.

Hello, I have the same problem. However, my open Ai key is valid and I can use credits.

What should I do on the installation?