Problem loading data in executions list in workflows

Describe the problem/error/question

Hello,

In executions where the Auto Refresh checkbox is checked, after a few refreshes, the list of executions will be empty and show errors. I have attached a screenshot of the error in the UI, along with the request containing the error with status of 500. Another way to reproduce this error is when Auto Refresh is not checked, and I scroll down the executions list to the end. I encounter this error in such cases as well

The second screenshot illustrates the errors. After a minute of having Auto Refresh checked, the list is repopulated after being empty.

What is the error message (if any)?


Please share your workflow

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 1.29.1
  • Database (default: PostgreSql): PostgreSql
  • n8n EXECUTIONS_PROCESS setting (default: own): queue
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system:

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hi @ali_fattahi :wave: Welcome to the community :tada:

I can’t reproduce this either on cloud or on my own self-hosted instance with postgres, can you maybe share your Docker compose file for your setup (obviously please redact anything sensitive) and also a workflow that you’re seeing this happen with that we can use to reproduce?