Problem loading data,Request failed with status code 500

Hi everyone, my n8n program is suddenly unavailable after running for some time, maybe I ran it and saved too many executions,but not even after I delete all it,It seems that everything about the workflow query is wrong,other interfaces are normal.

But the weird thing is that every time I restart n8n in Docker, he returns to normal, but only for a few dozen seconds,querying a single workflow also results in an error.

I changed the version on this machine, and the previous version 1.6.0 had this error, so I upgraded the version to 1.17.0.

I wonder if an SQLite database error is causing the problem.

  • **n8n version:1.17.0
  • **Database (default: SQLite):default
  • **n8n EXECUTIONS_PROCESS setting (default: own, main):?
  • **Running n8n via (Docker, npm, n8n cloud, desktop app):Docker
  • **Operating system: Ubuntu 22.04.2 LTS

Hey @jie,

It is hard to say what is going on there, I suspect something has changed on your server / host and that is causing some problems but I can’t see what they might be.

Can you share your n8n configuration, I take it your are using some environment variables as well.

is docker-compose.yaml file ?

version: ‘3.8’
image: n8nio/n8n:1.17.0
- 5678:5678
#- n8n_data:/home/node/.n8n
- /etc/localtime:/etc/localtime:ro
- TZ=Asia/Shanghai
#command: n8n start
restart: always

external: true

Hey @jie,

that looks like it should be ok, have you tried in private browsing mode maybe there is a browser extension getting in the way.

like this?

Yup like that, I can’t think of anything that would cause that to fail unless something with the database went wrong. What happens if you make a backup of your database and let n8n create a new one does that work?

The stacktraces suggest that the docker image contains some kind of an APM that is monkey-patching nodejs and expressjs.
Can you please tell us about what modifications your docker image contains?
Please also try running n8n without the modifications, and let us know if that works.

Thank you very much. APM is indeed the cause.

1 Like

Thank you very much. APM is indeed the cause. Just change the machine。

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.