Problem running workflow SQLITE_ERROR: table execution_entity has no column named data


Problem running workflow SQLITE_ERROR: table execution_entity has no column named data

Version: 0.233.1

1 Like

We are having the same problem … Workflows aren’t running anymore :frowning:

Yes,same to me.

Upgrading to 0.235.0 has made Workflows start working again …

I encountered same problem after updating to 0.233.1. The workflow stopped working and displayed SQLITE_ERROR: table execution_entity has no column named data in logs.

Afterwards, I went to the WebUI and checked the run history, but it displayed the error message Problem loading data with SQLITE_ERROR: no such column: execution.workflowData

Rolling back to 0.233.0 did not fix the issue, it still outputs the same error. It appears that the database may have been damaged during the upgrade process.


Are you all using docker and is it set to manually update?

To resolve the issue if you are not using MySQL set the version tag to 0.234.0 or 0.235.0, We found an issue issue with the MySQL migration yesterday and changed the latest version from 0.234.0 back to 0.233.1, Sadly for anyone who auto updates their containers or runs a docker pull every day they would run into this issue.

0.234.0 had a database migration in it that can’t be reversed so when it went back down to 0.233.1 it started to cause this issue.

We will work on making sure this doesn’t happen again.

Jey @Jon

Yeah, using Docker but not MySQL and keeping the :latest tag updated … manually moving to 0.235.0 circumvented the problem.


I use n8nio/n8n:latest
nothing changes.

Hey @aston_he,

Latest is currently 0.233.1 it was briefly 0.234.0, If you swap out latest for 0.234.0 or 0.235.0 it will solve the issue. We are also releasing 0.235.1 later today which will fix the issue for anyone using MySQL.

waiting for Latest.

same for me:

any flow has this error using POSTGRES database

yes i use n8n:latest also and auto update

Hey @RedPacketSec,

Change the latest tag to 0.234.0 or 0.235.0 that will get you up and running again.

1 Like

yup, this is working again now. Just let me know when fixed so i can swap it back to latest :wink:
cheers @Jon

1 Like

Hello, I have the same issue with that. Im using PORTAINER for managing my docker.
If i want to recreate I only have the optio of using last image and update only to 0.233.1


Can anyone help me to update my version to 0.235.0 and solve this issue?



Many thanks in advance!!

Hey @MaaPer,

In Portainer if you edit your image you can set the version in the image field like below.


Hey @RedPacketSec,

0.234.1 fixes this issue and is tagged with latest you should be good to swap back.


confirmed, thanks again @Jon

1 Like

I am using Queue mode with Postgres 14.5

early today I upgraded from 0.232.0 to 0.236.3

then those errors was happening

Entity_id", "ExecutionEntity"."data" AS "ExecutionEntity_data", "ExecutionEntity"."finished" AS "ExecutionEntity_finished", "ExecutionEntity"."mode" AS "ExecutionEntity_mode", "ExecutionEntity"."retryOf" AS "ExecutionEntity_retryOf", "ExecutionEntity"."retrySuccessId" AS "ExecutionEntity_retrySuccessId", "ExecutionEntity"."status" AS "ExecutionEntity_status", "ExecutionEntity"."startedAt" AS "ExecutionEntity_startedAt", "ExecutionEntity"."stoppedAt" AS "ExecutionEntity_stoppedAt", "ExecutionEntity"."workflowData" AS "ExecutionEntity_workflowData", "ExecutionEntity"."workflowId" AS "ExecutionEntity_workflowId", "ExecutionEntity"."waitTill" AS "ExecutionEntity_waitTill" FROM "public"."execution_entity" "ExecutionEntity" WHERE ("ExecutionEntity"."id" = $1) LIMIT 1 
Problem with execution 167007: column does not exist. Aborting.

I followed your instructions and downgrade it to 0.234.1,
then the errors stopped

but if I try to bounce back to 0.236.3 or any other superior version (0.235.0 for example) the Workflows fails again,

I am missing something?

thanks in advance for your support

ERRATA: start happening again in version 0.234.1 :roll_eyes:
ERRATA2: downgrade to 0.234.0 didnt worked either

ERRATA3: I think it is now working properly again!
I think it was a “layer 8” issue: I forgot to update a worker docker-compose with the same version of the rest.

Just one question @Jon
normally, I update my instances manually, updating the docker-compose image tag.

so, what is the proper way to do it?

just jump to the latest version?
or, should I upgrade step by step for every version until the last one?

thanks in advance for your support!

Hey @jfcaringi,

To upgrade it is normally just a case of pulling the tag you want and everything would be all good, Assuming a production environment you would also want to make backups first which is best practice for any software update.

1 Like