Problem with SQLite

Describe the issue/error/question

After saving the first workflow, I created another one, which while saving said I wasn’t the owner and to ask the owner to share it with me. (I didn’t go through the account setup, maybe that was it - but the first one worked fine)

Then I get this error message when I tried to re-create it:
Screenshot from 2023-03-31 17-01-26

Is the SQLite version buggy and we should use PG instead?
I have no problem doing that just don’t want to get into it if SQLite is the best option.

Also, is there a stable version? I encountered a lot of bugs so far. Including another one where the app crashes because I’m watchiing a folder with a lot of files in it (defalt settings tried to watch the subtree)

Please share the workflow

Empty workflow

Information on your n8n setup

  • n8n version:

  • Database you’re using (default: SQLite):

  • Running n8n with the execution process [own(default), main]:

  • Running n8n via [Docker, npm,, desktop app]:
    docker compose

Hi @Michal_Hantl, I am sorry you are having trouble. Version 0.222.0 of n8n is rather buggy and has been removed again from Docker Hub.

Perhaps you can try deleting your old database, and try re-starting n8n with the current n8nio/n8n:latest image (you might need to explicitly run docker pull n8nio/n8n:latest depending on how your docker compose file looks like)? This should launch [email protected] which hopefully causes less trouble.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.