Problems HTTP Request for Webhook [ version [email protected] ]

Describe the problem/error/question

I updated to version [[email protected]] and my HTTP request node for the webhook started showing the error:

ERROR: The resource you are requesting could not be found
404 - “{“code”:404,“message”:“The requested webhook "adsclassify" is not registered.”,“hint”:“Click the ‘Execute workflow’ button on the canvas, then try again. (In test mode, the webhook only works for one call after you click this button)”}”

Note that the webhook address is correct, the Post method is correct. I’ve tried downgrading to the previous version 1.24.0 (Beta) and encountered the same problem!

What is the error message (if any)?

Please share your workflow

Share the output returned by the last node

ERROR: The resource you are requesting could not be found
404 - “{"code":404,"message":"The requested webhook \"adsclassify\" is not registered.","hint":"Click the ‘Execute workflow’ button on the canvas, then try again. (In test mode, the webhook only works for one call after you click this button)"}”
Details
Time
17/01/2024, 18:30:07
Item Index: 0

HTTP Code
404

Stack

NodeApiError: The resource you are requesting could not be found
    at Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/HttpRequest/V3/HttpRequestV3.node.js:1564:27)
    at processTicksAndRejections (node:internal/process/task_queues:95:5)
    at Workflow.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/Workflow.js:698:19)
    at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/WorkflowExecute.js:656:53

Information on your n8n setup

  • n8n version:1.24.1
  • **Database (default: SQLite):cloud
  • **n8n EXECUTIONS_PROCESS setting (default: own, main):cloud
  • Running n8n via (n8n cloud): cloud
  • **Operating system:Mac OS - 14.2.1

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @Eduardo_Moscatelli,

Welcome to the community :tada:

The webhook-test url is only active when you are testing the webhook with the “Listen for Test Event” or “Test Workflow” option. Looking at your screenshot for workflow 2 it is not running in testing mode, If your workflow is active then you would need to use the Production URL instead.

It may also be useful to know that rather than triggering an n8n workflow using the http request > webhook approach which would use 2 executions from your allocation you can use the Execute Workflow node instead.

Nice to meet you, @Jon ,
The screenshot of workflow2, although not showing that the workflow was active for execution, I always left it running during my tests. The screenshot was more to show that the webhook URL entered was the same one I had inserted in the http request node.
The problem started occurring when I updated to the new version of n8n, the http request is not able to access the webhook through the internal flows of n8n. I tested this same webhook by calling it from an external tool, and it works normally. This shows, in my view, to be a problem with n8n for this new version.

Regarding the suggestion to use Execute Workflow, in the previous version I stopped using it because I couldn’t pass data from one flow to another (again some bug), that’s why I opted for the http request webhook (which worked until I updated to the new version).
But following the suggestion, I just tested using Execute Workflow, and to my surprise, even putting the correct code from workflow2 (see screenshot), it showed an error that seems completely out of context, which once again makes me suspect that there is a bug in n8n for this new version.


One of the reasons I updated to this new version was the hope of solving another apparent bug that even when pinning data in an http request node, it was not keeping the pinned data during execution.

At the moment, I am unable to make the connection from workflow1 to workflow2 due to these possible bugs. My development is stalled, I can’t downgrade to version 1.15 as the only options that appear are n8n version:1.24.1 and n8n version:1.24.0 (Beta).

I would be grateful if you could help me find out what is happening.

Thank you very much!

Hey @Eduardo_Moscatelli,

That is unusual, Sadly when responding to these we can only go on the information provided at the time. The error you are seeing in the http request node is fairly standard but it is possible that maybe something changed that is preventing it from being registered, When you click the test event button does it spin and wait for the connection or does it show an error?

With the execute workflow error the sub workflow doesn’t have access to all of the previous nodes in the calling workflow and this is case it is telling you that the webhook node is not in workflow 2, The way to use a sub workflow is to use a set node first and in there set the variables that you want to pass to the workflow, In a sub workflow it only takes the data from the node before it.

With pinned data it should only be used when you are testing the workflow from the UI and not when running the workflow from a schedule / in the background. When you are seeing the issue with pinned data is it when testing manually?

1 Like

@Jon
Http Request for Webhook Error
[question] When you click the test event button does it spin and wait for the connection or does it show an error?
The error occurs at the end of the execution of workflow1, in the last http request webhook node for workflow2. I’m not sure if I understood your question correctly, but when I click on test workflow it doesn’t show any error, it just leaves workflow1 active waiting for a request coming from a frontend tool (weweb) - note: my first node of workflow1 is a webhook.

Execute Workflow Error

To pass data from one Execute Workflow to another flow, you just need to have a previous node passing all the data you’d like, right? That’s exactly how I did it in the previous version of n8n, which wasn’t passing the data to workflow2 (although it at least called it). What’s not clear is why, even after entering the correct code from workflow2’s database in the Execute Workflow node of workflow1, it gives an error that seems completely out of context to me. The same procedures that I did in the previous version of n8n, which worked, are no longer working in this version. Do you know why the Execute Workflow node is not calling Workflow2?

Pinned Data Bug
[question] When you are seeing the issue with pinned data is it when testing manually?
Yes, I was performing the manual test. I pinned the data in the node, and then reran the flow manually, but the pinned data was ignored.

In my understanding, the errors in the Http request webhook and the Execute Workflow are not due to any wrong configurations I made, because I replicated the same settings, tests, and procedures that worked in the previous version of n8n. Therefore, I suspect that after this update something must have been corrupted in my n8n cloud. Even the last unsuccessful test I did was to ask my colleague to test the n8n cloud by opening the browser on another operating system (windows, mine is macOS) and the same problems occurred.

Since I don’t have the option to downgrade, do you have any tips on how I can proceed?

Hey @Eduardo_Moscatelli,

Http Request for Webhook Error
Does it work if you use the production URL? I have just done a test on my cloud instance using 1.24.1 and this looks to be working as expected for me. I have created a quick video here: Loom | Free Screen & Video Recording Software | Loom which shows the issue you are seeing and what happens if the workflow is testing. It would be handy if you could record a similar video so I can actually see what you are doing as to me this appears to be ok.

Execute Workflow Error
The node is trying to call workflow 2 but looking at the error a node in workflow 2 is trying to access data from a node that doesn’t exist, I suspect this is a node that is in Workflow 1 but I can’t see your workflows to verify this.

Pinned Data Bug
How do you know the pinned data was ignored? I have also created a quick video for this one: Loom | Free Screen & Video Recording Software | Loom In this video I am connecting to the webhook-test url which you can see is not active and I have the pinned data from the previous video, If pinned data wasn’t working I would expect it to try and connect to the webhook url that is not active and an error to occur but in this case it looks to be working.

Normally if your n8n cloud instance was corrupted you wouldn’t be able to open any workflows at all so as you are access them I don’t think that is the case here, It could be worth trying a smaller test to see if maybe adding the nodes again will help but issues like this are always tricky as I am not able to reproduce the same thing using the same version of n8n as you on the same system.

If you could make a video showing the first and third issue that would be really helpful so I can get a better understanding of what is happening while the workflow is running.

Hi @Jon ,
I conducted the tests for the Http Request Webhook:

Http Request Webhook - Successful Test :white_check_mark:
When I manually started the workflow (“When clicking Execute Workflow”), we see that the HTTP request successfully called the webhook.
https://recordit.co/4Z28acSTC3

Http Request Webhook - Failed Test :x:
For this test, the mere fact that I started the flow with the webhook caused an error condition. It seems that having this webhook to initiate the flow caused this error in the HTTP request webhook.
https://recordit.co/DmrfSkiQAu

Do you know the reason? Could this be a bug in the new version, or is there some conflicting configuration that I am implementing?

Hey @Eduardo_Moscatelli,

Interesting, Let me try that same setup and see what happens. One thing we can do for now is downgrade your cloud version to 1.15.2 to see if that helps while we work this out.

@Jon

Could you please downgrade to version 1.15.2?

I conducted a test for the Execute Workflow node, and it apparently does not work in this version.
https://recordit.co/vzmo1VCbcv

Regarding the pinned data that are being ignored, I will soon conduct a test and send it to you as well.

Thank you very much for the attention you have given to my case.

Hey @Eduardo_Moscatelli,

That looks like the execute workflow node has worked to me, You don’t see it running in the UI you need to enable the execution logging for it then you will see that it is working. We do have a feature request open to have it work how you are expecting it to but I can confirm the execute workflow node is working as expected in that version.

I will kick off the downgrade for your instance now.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.