Problems with Filemaker node

Dear Community,

I am running a self hosted n8n and a self hosted filemaker instance.

i could use this curl command to authenticate towards my filemaker database, that works fine.
But i can not get n8n work, i have tried the dedicated FilemakerNode or Http request neither of this.

curl --insecure --location --request POST ‘https://{ServerAddress}/fmi/data/v1/databases/{DatabaseName}/sessions’
–header ‘Content-Type: application/json’
–header ‘Authorization: Basic {Base64EncodedLogin}’
–data ‘’

If i try to import the curl commands, it says format is invlaid…

Can you give me any hint what can be done ?
Maybe the fact that i use Base64 encoded login and n8n only asks for plan login details is the problem?

n8n version: 0.210.2
Filemaker version: running filemaker on macOS

Hey @rhovath94,

Welcome to the community :tada:

Do you get any error messages?

ERROR: Login fail with the filemaker node

(if i take an “execute command” node and copy paste the curl into that, is also works. but i have no idea how to continue from there to continue getting records out of filemaker)

Hey @rhovath94,

So it looks like in n8n you need to put the username and password we then connect to Filemaker to get the token.

In the node for the Host you would also need to put just the Server Address not the protocol but the bit that may really cause an issue is if you are using a self signed certificate as it looks like we don’t support that option for the Filemaker node.

well, i have tried with the user name and pass of course did not work and i am certain that i using the correct ones as i have generated the Base64 out of those.
Sefl signed ssl you mean? Can not you put the bypass ssl option to filemaker node aswell like you have it in the http reuqest one?


@rhovath94 yes self signed SSL, We could add the option in but I am not sure when that would be. I have a few bits to catch up on today but I can see if I can fit it in at some point this week.

awsome Jon, thank you very much for your anwsers!

actually i have an instance in production with proper SSL, and that one doesen’t work either. i am not sure the ssl is the problem, i will keep on trying and look for a solution…

Hey @rhovath94,

It could just be that the credentials are wrong which would be unusual, Is your Filemaker instance available over the web? Like could you DM me the address host, database and some test credentials?