Problems with webhook (not listening)

Hey guys! I’m facing a real strage problem here. I’m trying to listen to data provenient from a GET webhook and it’s simply not receiving anything. Completely strange. I’ve watched many YT videos explaining how to do configure the webhook, and it seems 100% identical to the toutorials.

I’ve tryied the test and production and neither fucntion.

My worflow, in principle is absolutely simple. I’m just trying to listen to the information from the webhook.

I’m using the trial account.

Can somebody please help me out?

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @Julio_Dall_agnol,

assuming you created a webhook trigger node with a GET verb, you cannot receive information of a potential body which is sent by the caller of the webhook. This is because by convention GET requests should not have a body.

You need to change the verb of the webhook trigger node to PUT or POST.




Hey Nico, how are you?

Well, I’ve tried all these methods and it didn’t worked very well. Indeed, I couldn’t “listen” to anything in the test event.

And the most curious thing is that using zapier or other tools the webhook works.

I’m very confuse.

Are you pressing “Listen for test event” or activating the workflow?
Are you using the correct link? One is for testing only and the other only works when the workflow is activated.

Try testing a get webhook event by listening for it then pasting the test link in a separate tab and going to that url. That should register in n8n as a get request.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.