Problems with Zoom Node OAuth2 API

Zoom WJT Auth will be deprecieted soon. I am trying to set my Oauth following the steps that I found in de Zoom Node documentation. Got this message when trying to activate the app in the zoom marketplace: Something went wrong. Please try again!
URL: https://oauth.n8n.cloud/oauth2/callback?code=jVFwbn8XCI9WsH3MtDkTyuyGxEKV4zRXw

My credentials worok fine when using de Zoom node but not when trying to use endpoints thru http request node.

Apparently as the last step on the settings did not work (the callback) the credential has not permissions in the scope.

I am working on N8N cloud.

Hey @Samuel_Moguilner,

That is interesting, I am not sure why the authentication fail unless there is a scope issue. We have just released 0.229.0 which will include more useful errors but it won’t be available on cloud for a few days. I suspect this may show us what is going on and we will be able to work it out from there.

For now though I would double check the settings and maybe recreate the credential and see if that helps.

It may also be worth sticking with JWT for now until the new version is available as well so that it doesn’t block you from building.

1 Like

Hi Jon, thanks for your answer.

I did double check everything and recreated the credential. Still do not work.

I would not have problem to continue on JWT but zoom announced its depreciation https://developers.zoom.us/docs/internal-apps/jwt-app-migration/

I have my all operations working on workflows based on JWT credentials on N8N and need to move to oAuth ASAP. Do you have any recommendation to solve the problem with the callback?

Hey @Samuel_Moguilner,

Using JWT was a temporary solution until 0.229.0 is available which has more information on OAuth issues.

I have however just given this a go on my cloud account and I can connect without any issues, Can you share the settings you have configured in Zoom and where you see the error message as I suspect this could be a configuration issue with the Zoom app.

Hi Jon!
Following the settings in zoom, my credential settings in N8N and the callback error ( (https://oauth.n8n.cloud/oauth2/callback?code=EoBfmyDuLVzZz3xFZm2QaCg54CLHVKOTw)



Hey @Samuel_Moguilner,

I have the Subdomain check disabled other than that it is the same.

Hi @Jon , I’ve been exploring different options to resolve the issue. I tried deleting and reinstalling both the Zoom apps and the credentials. Additionally, I experimented with using both the HTTP node and the Zoom node. Unfortunately, I encountered the same error related to callbacks and scopes. Do you have any suggestions on how to proceed?

Hey @Samuel_Moguilner,

Annoyingly I can’t think of anything, I have gone through the setup a couple of times and it seems to work for me which is of course not really a good answer.

Did you try with the subdomain check disabled? That is the only difference that I can see. Have you also tried on a newer version of n8n?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.