Qdrant search query with payload

I have set up Qdrant docker on a server with 30 GB RAM and 16 cores CPU. I imported 10 million points with a vector dimension of 7 and a payload size 6. I now run 100 queries on it every second with a limit of 3000. The results I have observed are as follows:

  • When I set with_payload to true, the query time is 8s
  • When I set with_payload to false, the query time is 1.2s

I have tried setting on_disk_payload to false, but it did not improve the query estimated time with payload. Why is the estimated time longer when the payload is set to true compared to false?

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @Ahmad_Faazeli,

Welcome to the community :cake:

I have just taken a quick look at the Qdrant node as I am not that familiar with it, Where are you setting the with_payload option in it?

Hi @Jon
Thank you very much. The option mentioned is configured within the query.

Hey @Ahmad_Faazeli,

Can you share an example? I am just trying to work out if this is an issue with how we have implemented the node or if it is something else.

By using the Java client, I create points with an array of decimal numbers as a vector and Jason of the key and value for the payload.

Hey @Ahmad_Faazeli,

Are uou using n8n in the process at all?

I apologize for my misunderstanding of the nature of this forum, and I now comprehend the purpose of n8n and the reason why questions are being asked here.

1 Like